[PC-BSD Testing] Installation bug report 7.1 BETA1

tvb377 at gmx.de tvb377 at gmx.de
Fri Mar 27 01:10:29 PST 2009


Hi,

being new to this list (and PCBSD), please take my apologies
if I report already known bugs.

I installed PCBSD 7.1-BETA1 amd64 on an AMD64 dual core from a DVD.
I noticed:
1) could not install onto a USB harddisk.
   da<x> did not show up in the partition manager while being
   reported by the kernel's boot messages correctly.
2) then reverted to an internal SATA disk.
   That one already had slices + (FreeBSD) partitions on it, leaving no
   space on the disk (as I noticed later).
   Clicking on ad0 did not show space to install.
   I clicked "use entire disk", being a way to proceed.
   The installer then hung endless, the last message saying something
   like "mounting source media".
   Next time I tried to check the advanced partition editor.
   That reported the partitions incorrectly (-512MB as a size), and
   I was unable to delete them. Blindly proceeding anyway led to the same
   result as with entire disk.
   I could only install by manually deleting the partitions with another
   partition editor. Then everything went fine.
   It seems that at least the "entire disk" checkbox does not lead to
   repartitioning + formatting of the hard disk.
   IMHO, the check box "advanced" that allows you to edit the partitions
   should be a button opening a dialog, if possible. That I feel would
   be clearer.
3) The installer should give the user the opportunity to change his
   user id (maybe with an "advanced" button ?).
4) I configured X to use "vesa" and 1920x1200. That does not seem to
   work. It uses silently 1600x1200.
   I later switched to radeonhd and 1920x1200. That worked well.
5) nice to have: selecting a non-us keymap should result in a console
   keymap selected in rc.conf. That did not work.

Otherwise, PCBSD looks really nice! I particularly like the PBI stuff!

If I can test something for you of the above again, please notify me.

Cheers
Titus



More information about the Testing mailing list