[PC-BSD Testing] libX11 config failure

Larry Gadallah lgadallah at gmail.com
Mon Mar 23 22:01:58 PST 2009


Hi Kris:

On 23/03/2009, testing-request at lists.pcbsd.org
<testing-request at lists.pcbsd.org> wrote:
>>>  >
>>>  > For some reason, configuration for libX11 fails on the current ports
>>>  > tree (fetched via portsnap). For your reference, I have attached the
>>>  > config.log file per the error messages below:
>>>  >
...
>>>  > checking for cpp... /usr/bin/cpp
>>>  > checking if /usr/bin/cpp requires -undef... yes
>>>  > checking if /usr/bin/cpp requires -traditional... yes
>>>  > checking whether to use XCB... (cached) yes
>>>  > ./configure: 21141: Syntax error: word unexpected (expecting ")")
>>>
>>> bash updates have been problematic for configure lately.  $() was
>>> fixed shortly after a recent bash4 update.  If you got bash4 during
>>> the short "broken" window, try updating or uninstalling bash
>>> temporarily.
>>>
>>> It might be something like that.
>>>
>>
>> Thanks for the quick response. Alas, that didn't fix it either.  I got
>> exactly the same error for this version of bash:
>>
>> [root at pinawa /usr/ports/x11/libX11]# bash --version
>> GNU bash, version 3.2.48(1)-release (amd64-portbld-freebsd7.0)
>> Copyright (C) 2007 Free Software Foundation, Inc.
>>
>> Cheers,
>
>
> Ahh, try this:
>
> # ln -s /bin/bash /usr/local/bin/bash
>
> Does it work now?

Nope. I tried linking bash 3.x (/bin/bash) to /usr/local/bin/bash and
linking bash 4.x (/usr/local/bin/bash) to /bin/bash. Same results in
either case after a "make distclean" and "make".

>
> We ship a static version of bash in /bin/, which may be causing problems
> if the scripts have #!/usr/local/bin/bash in their header.
>

Cheers,
-- 
Larry Gadallah, VE6VQ/W7                          lgadallah AT gmail DOT com
PGP Sig: 917E DDB7 C911 9EC1 0CD9  C06B 06C4 835F 0BB8 7336


More information about the Testing mailing list