[PC-BSD Testing] Testing Digest, Vol 26, Issue 21

Ian Robinson fitchkendall at gmail.com
Sat Mar 14 07:47:13 PST 2009


Re: 7.1Alpha_x to install ports because of "need GNU m4 1.4 or later:
/usr/local/bin/gm4", it was said:

"The problem installing ports in 7.1 should be fixed for 7.1-BETA1 and
later. We had to write a small feature for FreeBSD  in order for it to
work with two LOCALBASE variables properly, it was issues with
ldconfig and ld-elf.so causing it to fail usually. That fix will be in
the next ISO :)"


The problem still exists:

root at pcbsd# cd /usr/ports/multimedia/kaffeine && make install clean
===>   kaffeine-0.8.7_2 depends on file: /usr/local/bin/moc - not found
===>    Verifying install for /usr/local/bin/moc in /usr/ports/x11-toolkits/qt33
===>   qt-3.3.8_9 depends on executable: qmake - found
===>   qt-3.3.8_9 depends on file:
/usr/local/libdata/pkgconfig/inputproto.pc - found
===>   qt-3.3.8_9 depends on file:
/usr/local/libdata/pkgconfig/xinerama.pc - found
===>   qt-3.3.8_9 depends on file: /usr/local/libdata/pkgconfig/sm.pc
- not found
===>    Verifying install for /usr/local/libdata/pkgconfig/sm.pc in
/usr/ports/x11/libSM
===>   libSM-1.1.0_1,1 depends on file:
/usr/local/share/aclocal/xorg-macros.m4 - found
===>   libSM-1.1.0_1,1 depends on file:
/usr/local/libdata/pkgconfig/xtrans.pc - found
===>   libSM-1.1.0_1,1 depends on file:
/usr/local/libdata/pkgconfig/ice.pc - found
===>   libSM-1.1.0_1,1 depends on file:
/usr/local/libdata/pkgconfig/xproto.pc - found
===>   libSM-1.1.0_1,1 depends on file: /usr/local/bin/automake-1.10 - not found
===>    Verifying install for /usr/local/bin/automake-1.10 in
/usr/ports/devel/automake110
===>   automake-1.10.1 depends on file: /usr/local/bin/perl5.8.9 - found
===>   automake-1.10.1 depends on file: /usr/local/bin/autoconf-2.62 - not found
===>    Verifying install for /usr/local/bin/autoconf-2.62 in
/usr/ports/devel/autoconf262
===>  Building for autoconf-2.62
gmake  all-recursive
gmake[1]: Entering directory `/usr/ports/devel/autoconf262/work/autoconf-2.62'
Making all in bin
gmake[2]: Entering directory
`/usr/ports/devel/autoconf262/work/autoconf-2.62/bin'
autom4te_perllibdir='..'/lib AUTOM4TE_CFG='../lib/autom4te.cfg'
 ../bin/autom4te -B '..'/lib -B '..'/lib         --language M4sh
--cache '' --melt ./autoconf.as -o autoconf.in
autom4te: need GNU m4 1.4 or later: /usr/local/bin/gm4
gmake[2]: *** [autoconf.in] Error 1
gmake[2]: Leaving directory
`/usr/ports/devel/autoconf262/work/autoconf-2.62/bin'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/devel/autoconf262/work/autoconf-2.62'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/devel/autoconf262.
*** Error code 1

Stop in /usr/ports/devel/automake110.
*** Error code 1


However, I am very happy to report that except in the few instances
reported in the testing lists -- and it seems there is very little
being reported -- 7.1 Beta is a very reliable and smooth system.


Ian Robinson
Salem, Ohio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20090314/21e60a19/attachment-0001.html 


More information about the Testing mailing list