[PC-BSD Testing] Is NVIDIA driver 173.14.xx included in Beta 1?

Kris Moore kris at pcbsd.com
Tue Mar 10 08:03:44 PST 2009


That's a typo on my part. The 173 driver is included, but you may want take a look at the nvidia thread from yesterday, I added a fix which updates the nvidia drivers to the latest versions, and fixes a few bugs.

------Original Message------
From: Geoff Gigg
Sender: 
To: testing at lists.pcbsd.org
ReplyTo: di874 at ncf.ca
ReplyTo: PC-BSD Testing list
Subject: [PC-BSD Testing] Is NVIDIA driver 173.14.xx included in Beta 1?
Sent: Mar 10, 2009 11:56 AM

Sorry if this question has been dealt with elsewhere already ...

I noticed on the Beta 1 Release notes page
http://www.pcbsd.org/content/view/95/11/ that only these NVIDIA drivers
are included:

  - Nvidia Driver 180.35
  - Nvidia Driver 96.43.07
  - Nvidia Driver 71.86.06

Is there some reason why the 4th NIVIDIA driver listed on
http://www.nvidia.com/object/unix.html is not included?

    FreeBSD x86
    Latest Version: 180.29
    Latest Legacy GPU Version (71.86.xx series): 71.86.09
    Latest Legacy GPU Version (96.43.xx series): 96.43.07
    Latest Legacy GPU Version (173.14.xx series): 173.14.12

(I guess the above list is a little behind the latest release numbers.)

I have a GeForce FX5200 and according to this page that lists the NVIDIA
cards and device IDs (http://www.nvidia.com/object/IO_18897.html), it
requires the 173.14.xx driver.

     The 173.14.xx driver supports the following set of GPUs:

     NVIDIA GPU Products:
     GeForce PCX 5750 	0x00FA
     GeForce PCX 5900 	0x00FB
     Quadro FX 330/GeForce PCX 5300 	0x00FC
     Quadro FX 330/Quadro NVS 280 PCI-E 	0x00FD
     Quadro FX 1300 	0x00FE
     GeForce FX 5800 Ultra 	0x0301
     GeForce FX 5800 	0x0302
     Quadro FX 2000 	0x0308
     Quadro FX 1000 	0x0309
     GeForce FX 5600 Ultra 	0x0311
     GeForce FX 5600 	0x0312
     GeForce FX 5600XT 	0x0314
     GeForce FX Go5600 	0x031A
     GeForce FX Go5650 	0x031B
     Quadro FX Go700 	0x031C
     GeForce FX 5200 	0x0320
     GeForce FX 5200 Ultra 	0x0321
     GeForce FX 5200 	0x0322
     ...

(Note that NVIDIA page http://www.nvidia.com/object/IO_32667.html gives
the impression that only the 96 and 71 series drivers are required to
support legacy NIVIDIA cards, but I think it is out of date.)

I have not downloaded the Beta 1 yet, so maybe the 173 driver is there
and the Release notes are just not in synch with that? If that's the
case, sorry for this lengthy mess.

Finally, here's a reference to a posting by the NVIDIA driver maintainer
about the latest 173.14.16 release for FreeBSD and its requirements:
http://www.nvnews.net/vbulletin/showthread.php?t=127014

Thanks for any feedback,

Geoff Gigg

(And thanks for all the hard work that goes into PC-BSD!)

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing

!DSPAM:1,49b68d43202641803979629!




--
Kris Moore
PC-BSD Software


More information about the Testing mailing list