[PC-BSD Testing] 7.1 Beta1

Kris Moore kris at pcbsd.com
Mon Mar 9 07:07:44 PST 2009


Bill Leeper wrote:
> Kris Moore wrote:
>> Bill Leeper wrote:
>>  
>>> Sorry about that, I should have included more info. I have an 8500GT  
>>> with 512MB and I tried all three nVidia drivers and the nv driver. I  
>>> have a widescreen flat panel using a DVI connector. As soon as I 
>>> tell  it to apply the settings I get the text screen where it 
>>> generates a  new xorg. I then come back to the configure screen where 
>>> I get the  message previous attempt failed please check your settings 
>>> and try  again. This is pretty much the exact same problem I had with 
>>> the first  alpha as far as I can tell. I even tried the custom 
>>> settings to enter  the refresh rates and it makes no difference. The 
>>> settings section  does correctly identify my card as a GeForce 8500 GT.
>>>
>>>     
>>
>> Ok, here's what I need you to do in order for me to troubleshoot / fix 
>> this issue.
>>
>> Boot PC-BSD 7.1-BETA1, then hit "7" at the boot-splash to re-run the X 
>> setup tool. Try using the 180.35 driver as you normally would, then go 
>> ahead and hit Apply. After it fails, and you get brought up to the 
>> "Your previous attempt failed" screen, right-click on the desktop and 
>> bring up xterm, then run the following command:
>>
>> # tar cvf /root/xlogs.tar /PCBSD/tmp/xsetup.log /etc/X11 /root/xorg*
>>
>> Then go ahead and setup vesa mode as you've been doing, and e-mail me 
>> the /root/xlogs.tar file. I should be able to help get this resolved 
>> with that info :)
>>
>> -- 
>> Kris Moore
>>
>> _______________________________________________
>> Testing mailing list
>> Testing at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/testing
>>
>>   
> Here are the logs you requested.
> 
> Bill
> 

Ahh, ok found the problem:

(==) Using config file: "/etc/X11/xorg.conf"
dlopen: /PCBSD/local/lib/xorg/modules//libwfb.so: Undefined symbol 
"miZeroLineScreenIndex"
(EE) Failed to load /PCBSD/local/lib/xorg/modules//libwfb.so
(EE) Failed to load module "wfb" (loader failed, 7)
(EE) NVIDIA(0): Need libwfb but wfbScreenInit not found

Looks like I have a bug in one of the driver tbz files. The libwfb.so 
file isn't supposed to be replaced with nvidia's version anymore, 
otherwise you get this error. BTW, are you trying with the 180.35 driver 
first, or an older driver? I think the bug is in the 177 and 93 series 
driver, they probably remove the libwfb still, and cause this screwup.

I'll get those updated here shortly, and this bug should go away. If I 
send you a patch, will you be willing to test it?

--
Kris Moore



More information about the Testing mailing list