[PC-BSD Testing] RC2 - Dolphin Admin mode broken

Kris Moore kris at pcbsd.org
Tue Jun 30 09:28:24 PDT 2009



On Tue, 30 Jun 2009, Ian Robinson wrote:

> 2.  GUI Admin -- While opening Dolphin from the GUI in the Admin (root) mode (Start > System > FileManger Admin
> (sudolphin), it stopped with a blank file list window and the following error message appeared at the bottom of the
> window:
> 
> "Could not start process   Cannot talk to klauncher.  The name org.ked.klauncher was not provided by and .service files."
>

I'm having trouble duplicating this :( When I run it exactly the same way here, it comes up, and works without
issues, I can delete files in /root, and navigate elsewhere without issue.

Are you doing anything initially which I can try to duplicate this error?

> 4.  Launch in root terminal message -- fails but that seems normal to me.
> 
> [root at pcbsd]/home/IR(1)# kdesu dolphin
> No protocol specified
> kdesu: cannot connect to X server :0.0
> 
> [root at pcbsd]/home/IR(2)# dolphin
> <unknown program name>(99648)/: KUniqueApplication: Cannot find the D-Bus session server
> <unknown program name>(99646)/: KUniqueApplication: Pipe closed unexpectedly.


This is normal, since the app can't connect to X when run from a root shell.

> 5.  Konqueror works with the "% kdesu konqueror" command, but it loads v-e-r-y s-e-r-i-o-u-s-l-y  S-L-O-W and generates
> the same error message as kdesu dolphin:
> 
> IR at pcbsd]/home/IR(11)% kdesu konqueror
> kdesu(689) KLocalePrivate::initEncoding: Cannot resolve system encoding, defaulting to ISO 8859-1.
> kdesu(689) startApp: Daemon not safe (not sgid), not using it.

Those messages are from kdesu, and are normal.


--
Kris Moore
PC-BSD Software


More information about the Testing mailing list