[PC-BSD Testing] Testing 7.1.1-RC1

Kris Moore kris at pcbsd.org
Wed Jun 17 10:02:32 PDT 2009



--
Kris Moore
PC-BSD Software

On Tue, 16 Jun 2009, Arthur Koziol wrote:

>
>> Thanks for everybodies patience! I've been working to get 7.1.1
>> ready for testing, and the i386 ISO
>> is now ready to go:
>>
>> ftp://ftp.pcbsd.org/pub/iso/7.1.1-RC1/i386/PCBSD7.1.1-RC1-x86-DVD.iso
>>
>> I'm still working on prepping the amd64 ISO, and hope to have it
>> posted tomorrow sometime. The fixes for
>> it will be identical to the i386 though, minus the nvidia drivers of course.
>>
>> The changelog for 7.1.1-RC1 is as below. Please report your findings
>> back to this list so we can get 7.1.1
>> ready for a launch here in the near future. 7.1.1 will be the last
>> release to round-out the 7.x series, so
>> we can turn our attention to 8.0 and all the major updates that will bring.
>>
>>
>> PCBSD 7.1.1-RC1 - Changelog (06-16-09)
>> --------------------------
>> * Updated KDE to 4.2.4
>> * Updated Nvidia driver to 185.14 - 4071
>> * Updated FreeBSD to 7.2-Stable
>> * Fixed issues with using the fetch ports GUI causing a crash in
>> kcmshell4. - 4069
>> * Improved the System Updater Tray to not use annoying popups and
>> instead just change the icon - 4103
>> * Added the older Nvidia 71.86.xx driver - 4066
>> * Fixed issues with kppp, which needs suid permissions to function - 4061
>> * Moved /PCBSD to /usr/PCBSD and created sym-link to allow small
>> root partitions - 3999 - 4004 - 4008
>> * Fixed bugs when "upgrading" a system that uses ZFS root partition
>> - 3995 - 3997
>> * Added support to give higher / lower priority to wifi connections - 3871
>> * Added ability to edit saved wifi profiles - 3870
>> * Added ability to "ignore" updates in the updater tool - 3842
>> * Improved the system updater and tray application interaction - 3832
>> * Fixed CUPS issues not finding all .ppd files correctly - 3833 - 3834 - 3822
>> * Fixed bugs with xterm not running - 3804
>> * Improved the default fluxbox configuration - 3793 - 3794 - 3798 -
>> 3808 - 3809
>> * Improved the KDE4 default theme - 3805 - 3810
>> * Updated the KDM theme - 3812 - 3817
>> * Improved the KSplash Theme - 3811
>
> Ok, some initial things I noticed which beating on 7.1.1 RC.
>
> 1. The new loader screen and animation is slick.
> 2. Setting up display resolutions and testing modes is hella faster.
> XServer 1.6.1, I see?
> 3. KDE 4.2.4 is *much* more responsive. And yay, the KDE guys fixed
> the issue with text input field shrinking when a bad command or
> incorrect password is entered.
> 4. Running Portsnap in System Manager downloaded and did it's thing
> fairly quick but then sat at 100% progress complete / "new ports or
> files" for well over 10 minutes while the HD grinded away. Running it
> again an hour later, it finished quickly.

Fixing this now. The first time you run portsnap it has to build an index file, which
can take quite some sime. I'm going to add a check for this, so we can notify the user that
it may be a bit of time.

> 5. When you click Generate to get a diag sheet, it says could not
> start process but this is likely a KDE thing I'm guessing.

I'm looking into this. It only appears once though, which makes me think its some cache data
from KDE being regened which causes the error :(


> 6. Clicking System Settings > Display > Gamma shuts down Display
> Settings. I think this was also in 4.2.4 and is probably a KDE thing as well.

It seems to work here, what video card / driver?

> 7. Checking on Enable Desktop Effects" and clicking Apply throws a
> "Sorry...." error.

What video card / driver? Also, did you reboot before trying to apply the effects?


More information about the Testing mailing list