[PC-BSD Testing] Open Office template errors

Jeff dejamuse at yahoo.com
Mon Jul 13 15:08:13 PDT 2009


Awesome! Thanks for the fix.

Wasn't trying to bug you - just thought others should see the fix too as I doubt too many others monitor that list.

...Jeff

--- On Mon, 7/13/09, Kris Moore <kris at pcbsd.org> wrote:

From: Kris Moore <kris at pcbsd.org>
Subject: Re: [PC-BSD Testing] Open Office template errors
To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
Date: Monday, July 13, 2009, 5:19 PM


Jeff,

It takes a bit for me to get around to testing various things :) OpenOffice is a beast, so bear with us.

I did some digging, and I've found a workaround, not sure of a real bugfix yet though. Take a look at your
error you posted:

/usr/home/Jeff/.openoffice.org/3r/uno_packages/cache/uno_packages/yTznki_/OOOP-templates-separated-en-US-2.6.0.2.oxt/template/en-US/forms/Confidentiality_Agreement.ott does not exist

I installed a template package, and had the exact same error. So I delved into the .openoffice.org directory, and found the
directory "openoffice.org/3r/" doesn't exist. I created a symlink from openoffice.org/3 -> openoffice.org/3r. Then I cd to 3r, and noticed that "uno_packages" doesn't exist, its under user/uno_packages. I went ahead and made another sym-link in /home/kris/.openoffice.org/3r/:

 # ln -s `pwd`/user/uno_packages uno_packages

Then I booted up openoffice, and viola! I can see all the templates and use them just fine. So for some reason in the OpenOffice
extension manager, when it extracts / installs, it uses a weird path, which doesn't exist in the home profile.

We'll have to dig into OO source (shudder) to figure out why this is bugged.

In the meantime, you can use this workaround, and your templates should magically begin working again.


--
Kris Moore
PC-BSD Software

On Mon, 13 Jul 2009, Jeff wrote:

> Nobody monitoring pbi-bugs?
> 
> Reposting here as others may want to test this.
> -------------------------
> I was successful at importing some template pack extensions in the new Open Office release, but trying to access the templates results in
> this error:
> 
> Error creating a new document:
> /usr/home/Jeff/.openoffice.org/3/user/template  does not exist.
> 
> So I created that directory but then received another error when trying to open a template:
> 
> Error creating a new document:
> /usr/home/Jeff/.openoffice.org/3r/uno_packages/cache/uno_packages/yTznki_/OOOP-templates-separated-en-US-2.6.0.2.oxt/template/en-US/forms/C
> onfidentiality_Agreement.ott does not exist.
> 
> Ditto for all templates - the error persists, indexing through all the available templates.
> 
> !DSPAM:1,4a5b9499825691367518398!
>-----Inline Attachment Follows-----

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20090713/b4e211a1/attachment.html 


More information about the Testing mailing list