[PC-BSD Testing] Screen sharing

Walt Pawley walt at wump.org
Thu Feb 19 21:45:38 PST 2009


At 12:29 AM -0800 2/15/09, Walt Pawley wrote:
>Now that everyone is busy testing 7.1, I have an issue with -
>
>uname -a
>FreeBSD compaq 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #0: Mon
>Nov 24 20:22:16 EST 2008
>root at pcbsdx32-7:/usr/obj/pcbsd-build/cvs/7.0.2-src/sys/PCBSD
>i386
>
>- that I can't seem to find any discussion on.
>
>The tale: I ran a 1.5.1 system that was working well. If it had
>screen sharing, I was too dumb to find it so I used the x11vnc
>port instead. No problems that I could see. I put off upgrading
>until 7.0.2 seemed to settle down. I didn't look for screen
>sharing. I just installed x11vnc and started trying to use it.
>
>This did not work well. It seemed to behave as though the
>sleep/screen saver would kick in on the VNC window after only a
>few seconds. It could be awakened just about long enough to
>position the mouse and hit a button ... if you knew right where
>it was. So, I started looking for a reason. Still haven't found
>one but I did discover Screen Sharing.
>
>So, I tried it. It did not behave well either. It seemed to
>provide two screen images, offset by about a 1/4-inch, mushed
>together. On top of that are flickering, moving color blocks.
>
>The system seems to work well used at the console. No funny
>screen artifacts. No quick sleep or screen saver invocations.
>I've not changed my viewer, though I experimented with a range
>of its settings to see what the behavior would be, and am, in
>fact, using it to type this message right now (not via a PC-BSD
>machine, however).
>
>Anyone with similar results or sage advice or ???

Interestingly, either no one else has experienced this or it's
considered too elementary to bother commenting upon. I did find
out something about, none the less. I wrote Karl Runge about
x11vnc and it's apparent change in behavior moving from PC-BSD
1.5.1 to PC-BSD 7.0.2. He quickly and kindly pointed me to

<http://www.karlrunge.com/x11vnc/faq.html#faq-kde-screensaver>

which pointed out that if I'd been just a bit smarter I could
have solved my immediate problem all by myself. But it also
pointed out that the problem is old and was probably something
fixed in is PC-BSD's KDE3 that's reappeared in KDE4.
-- 

Walter M. Pawley <walt at wump.org>
Wump Research & Company
676 River Bend Road, Roseburg, OR 97471
         541-672-8975


More information about the Testing mailing list