[PC-BSD Testing] Webmin installed in jail (warden) thinks it's installed on host.

Jeff dejamuse at yahoo.com
Sun Dec 27 03:06:56 PST 2009


I have the webmin pbi installed.

I can't access the apache server I have running in a jail I setup with the warden.

So I installed webmin via ports while SSHed into the jail's IP address.

Went through the setup script ok - set password.

When I tried to access webmin it wouldn't accept the password, so on a hunch I didn't use the password field and it let me in.  Changed the password via webmin UI but again same results when trying to login again.

Suspected webmin thinks it's installed on the host system.

Tried to setup the apache server monitor but it can't find the executable when I specified the path: /usr/local/sbin  It didn't like this one either: /usr/local/warden/jails/192.168.1.12/usr/local/sbin

Also noted that the fields for the apache paths were prepopulated with paths beginning with  /Programs/...

Switched to webmin running from PBI and the password did not work - had to change it to the one I setup in the jail.  Once in I saw that the apache server config entries I made while in the jail, showed up here. Obvious conflict here - using wrong config files or something.

Did 'pkg_deinstall webmin' but got error: pkg_delete: pkg_do: unable to return to working directory /usr/local/lib/webmin

Note I was installing webmin version 1.5 from ports whereas the PBI version is 1.49

Seems to me I had done procedure a year ago or so and didn't run into this issue.

What's going on? How is it possible that anything I do in a jail can get outside it?

Tnx, Jeff











      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20091227/0af16879/attachment.html 


More information about the Testing mailing list