[PC-BSD Testing] Alpha 12152009 Up!

Kris Moore kris at pcbsd.org
Fri Dec 18 09:14:30 PST 2009


On Thu, 17 Dec 2009, A.Yerenkow wrote:
>
> 1. Kris, I have here da0s1a with install; it installs system OK, and
> after that it tries to install PBIs;
> I see in logs something like this:
> found cd - da0s1
>
> and mount gives me the same
> /cdmnt -> da0s1 instead of da0s1[a]

I'm not sure what exactly you mean. The system installs fine, but there is a 
problem mounting the CD? Or is this a USB image? By default it searches all
the device names, until it finds the valid device / install archive. If that
happens to be da0s1 instead of da0s1a, then I'm not sure how to override that,
since da0s1 may be correct in some cases.

>
> 2. I tried to install from usb flash to laptop pcsbsd, laptop died in
> the middle.
> just right after that I couldn't boot from usb - after I ran fsck, next
> boot was OK.
> I suggest to mount all needed files from source (dvd/cd/usb) in forced
> readonly mode, to avoid such things.
> And probably if device type is usb flash, check if there is need fsck
> and maybe run it? :)
>
>
>

I've changed the scripts to mount all USB images in readonly now, that should help prevent
that type of issue :)


--
Kris Moore
PC-BSD Software


More information about the Testing mailing list