[PC-BSD Testing] MS Font PBI not working?

Kris Moore kris at pcbsd.org
Tue Aug 25 12:10:37 PDT 2009



On my system, the only thing in /PCBSD/local/etc/fonts is a bunch of .conf files:

#ls /PCBSD/local/etc/fonts
alias.conf         conf.d             fonts.conf.default local.conf         msfonts-rules.conf
conf.avail         fonts.conf         fonts.dtd          misc.conf

However, if we poke around /PCBSD/local/lib/X11/fonts, heres what we find

# ls /PCBSD/local/lib/X11/fonts/TrueType
Arial.ttf     comic.ttf     courbi.ttf    fonts.dir     georgiai.ttf  timesbd.ttf   trebucbd.ttf  verdanab.ttf
Arialbd.ttf   comicbd.ttf   couri.ttf     fonts.scale   georgiaz.ttf  timesbi.ttf   trebucbi.ttf  verdanai.ttf
Arialbi.ttf   cour.ttf      encodings.dir georgia.ttf   minguni.ttf   timesi.ttf    trebucit.ttf  verdanaz.ttf
Ariali.ttf    courbd.ttf    fonts.alias   georgiab.ttf  times.ttf     trebuc.ttf    verdana.ttf   webdings.ttf

These are the real fonts, which if you symlink /Programs/Firefox*/lib/X11 -> /PCBSD/local/lib/X11 to, should
be finding.


--
Kris Moore
PC-BSD Software

On Tue, 25 Aug 2009, Jeff wrote:

> Same here, but those system fonts do not include the MS fonts from the PBI which are not in that X11 system directory, but rather in:
> /PCBSD/local/etc/fonts
> 
> --- On Tue, 8/25/09, Kris Moore <kris at pcbsd.org> wrote:
>
>       From: Kris Moore <kris at pcbsd.org>
>       Subject: Re: [PC-BSD Testing] MS Font PBI not working?
>       To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
>       Date: Tuesday, August 25, 2009, 2:54 PM
> 
> 
>
>       Here's what I have for FF, and it works just fine:
>
>       # ls -al /Programs/Firefox3.5.2/lib/X11
>       lrwxr-xr-x  1 root  wheel  20 Aug 25 12:11 /Programs/Firefox3.5.2/lib/X11 -> /PCBSD/local/lib/X11
>
>       When I start firefox and go to edit -> preferences -> content, and look at fonts, all my system fonts now show up.
>
>       --
>       Kris Moore
>       PC-BSD Software
>
>       On Tue, 25 Aug 2009, Jeff wrote:
>
>       > I made the link as you said, from FF to the system X11 directory, but FF cannot see the MS fonts which are in:
>       /PCBSD/local/etc/fonts. 
>       > Those two directories aren't connected:
>       >
>       > /PCBSD/local/etc/fonts
>       >
>       > /Programs/Firefox3.5.2/lib/X11/fonts  (where X11/fonts is the system directory, linked to FF)
>       >
>       > --- On Tue, 8/25/09, Kris Moore <kris at pcbsd.org> wrote:
>       >
>       >       From: Kris Moore <kris at pcbsd.org>
>       >       Subject: Re: [PC-BSD Testing] MS Font PBI not working?
>       >       To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
>       >       Date: Tuesday, August 25, 2009, 2:20 PM
>       >
>       >
>       >
>       >       Thats not the right link:
>       >
>       >       # cd /Programs/Firefox*/lib
>       >       # rm X11
>       >       # ln -s /PCBSD/local/lib/X11 X11
>       >
>       >       All the fonts are located in /PCBSD/local/lib/X11 on the system, you have to link this into the PBIs lib/ directory
>       >       so that it "shares" / uses the same fonts directory.
>       >
>       >       --
>       >       Kris Moore
>       >       PC-BSD Software
>       >
>       >       On Tue, 25 Aug 2009, Jeff wrote:
>       >
>       >       > That didn't work.
>       >       >
>       >       > I can't see how /PCBSD/local/etc/fonts  connects to  /Programs/Firefox3.5.2/lib/X11/fonts
>       >       >
>       >       > Don't I need a link from the latter to the former?
>       >       >
>       >       > More confusing...
>       >       >
>       >       > --- On Tue, 8/25/09, Kris Moore <kris at pcbsd.org> wrote:
>       >       >
>       >       >       From: Kris Moore <kris at pcbsd.org>
>       >       >       Subject: Re: [PC-BSD Testing] MS Font PBI not working?
>       >       >       To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
>       >       >       Date: Tuesday, August 25, 2009, 12:15 PM
>       >       >
>       >       >
>       >       >
>       >       >       Ahh, ok solved this here.
>       >       >
>       >       >       You'll need to do this for all PBIs you want to use the system fonts:
>       >       >
>       >       >       # cd /Programs/<PBI>/lib
>       >       >       # rm X11
>       >       >       # ln -s /PCBSD/local/lib/X11 X11
>       >       >
>       >       >       I did this here, and now my fonts in FF work perfectly. I'm guessing you have same
>       >       >       issue with OO as well, the etc/fonts link doesn't seem to matter in this case.
>       >       >
>       >       >
>       >       >       --
>       >       >       Kris Moore
>       >       >       PC-BSD Software
>       >       >
>       >       >       On Tue, 25 Aug 2009, Jeff wrote:
>       >       >
>       >       >       > Also have this path to X11 fonts: /usr/X11R6/share/fonts/TrueType
>       >       >       >
>       >       >       > Is there some way to centralize all the fonts?  The contents of /PCBSD/local/etc/fonts are not TTF files.
>       >       >       >
>       >       >       > Confusing...
>       >       >       >
>       >       >       > --- On Tue, 8/25/09, Jeff <dejamuse at yahoo.com> wrote:
>       >       >       >
>       >       >       >       From: Jeff <dejamuse at yahoo.com>
>       >       >       >       Subject: Re: [PC-BSD Testing] MS Font PBI not working?
>       >       >       >       To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
>       >       >       >       Date: Tuesday, August 25, 2009, 11:27 AM
>       >       >       >
>       >       >       >       That didn't work.  The link was made, but OO still cannot see system fonts.
>       >       >       >
>       >       >       >       BTW, I discovered this because Verdana was not available to Firefox, which is the most ubiquitous web
>       font.
>       >       >       >
>       >       >       >       --- On Tue, 8/25/09, Kris Moore <kris at pcbsd..org> wrote:
>       >       >       >
>       >       >       >             From: Kris Moore <kris at pcbsd.org>
>       >       >       >             Subject: Re: [PC-BSD Testing] MS Font PBI not working?
>       >       >       >             To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
>       >       >       >             Date: Tuesday, August 25, 2009, 9:16 AM
>       >       >       >
>       >       >       >
>       >       >       >
>       >       >       >             Jeff,
>       >       >       >
>       >       >       >             The font PBI installs fonts to the system folder properly, but it looks like OO, and probably
>       the other
>       >       PBIs
>       >       >       >             aren't
>       >       >       >             looking in the system folder for fonts. Give this a shot and let me know if it fixes it:
>       >       >       >
>       >       >       >             cd /Programs/OpenOffice*/etc
>       >       >       >             ln -s /PCBSD/local/etc/fonts fonts
>       >       >       >
>       >       >       >             start OO, do you have the fonts now? If so, I'll get that fix put into the PBIs right away.
>       >       >       >
>       >       >       >             As for KDE 4.3.0, it'll be included with PC-BSD 8.0 later this year.. Its a large update, since
>       it
>       >       moves us to
>       >       >       QT
>       >       >       >             4.5
>       >       >       >             and I'm having to fix up a lot of our tools to work on it :)
>       >       >       >
>       >       >       >
>       >       >       >             --
>       >       >       >             Kris Moore
>       >       >       >             PC-BSD Software
>       >       >       >
>       >       >       >             On Mon, 24 Aug 2009, Jeff wrote:
>       >       >       >
>       >       >       >             > I have the MS True-type font PBI installed, but can't see any of the fonts in FF3 or
>       OpenOffice or
>       >       Abi Word. 
>       >       >       >             Where exactly are they
>       >       >       >             > supposed to be available?
>       >       >       >             >
>       >       >       >             > I presume there's no UI for this PBI and it just installs fonts somewhere.
>       >       >       >             >
>       >       >       >             > Every application seems to have its own set of fonts with some that apparently come with
>       KDE.  There
>       >       are lots
>       >       >       >             of other available fonts
>       >       >       >             > out there but there's no good way of centrally managing them and installing them in KDE it
>       seems,
>       >       complicated
>       >       >       >             by the different font
>       >       >       >             > packaging techniques. Seems to me there used to be some KDE font manager/installer app but I
>       can't
>       >       find it in
>       >       >       >             the menu, and from what I
>       >       >       >             > remember, it wasn't especially useful.
>       >       >       >             >
>       >       >       >             > What to do?
>       >       >       >             >
>       >       >       >             > P.S., When might we expect an upgrade to KDE 4.3?
>       >       >       >             >
>       >       >       >             >
>       >       >       >             >
>       >       >       >
>       >       >       > -----Inline Attachment Follows-----
>       >       >       >
>       >       >       > _______________________________________________
>       >       >       > Testing mailing list
>       >       >       > Testing at lists.pcbsd.org
>       >       >       > http://lists.pcbsd.org/mailman/listinfo/testing
>       >       >       >
>       >       >       >
>       >       >       >
>       >       >       > -----Inline Attachment Follows-----
>       >       >       >
>       >       >       > _______________________________________________
>       >       >       > Testing mailing list
>       >       >       > Testing at lists.pcbsd..org
>       >       >       > http://lists.pcbsd.org/mailman/listinfo/testing
>       >       >       >
>       >       >       >
>       >       >       >
>       >       >       >
>       >       >
>       >       > -----Inline Attachment Follows-----
>       >       >
>       >       > _______________________________________________
>       >       > Testing mailing list
>       >       > Testing at lists.pcbsd.org
>       >       > http://lists.pcbsd.org/mailman/listinfo/testing
>       >       >
>       >       >
>       >       >
>       >       >
>       >
>       > -----Inline Attachment Follows-----
>       >
>       > _______________________________________________
>       > Testing mailing list
>       > Testing at lists.pcbsd.org
>       > http://lists.pcbsd.org/mailman/listinfo/testing
>       >
>       >
>       >
>       >
> 
> -----Inline Attachment Follows-----
> 
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
> 
> 
> !DSPAM:1,4a9434eb14801997012748!
>


More information about the Testing mailing list