[PC-BSD Testing] ktorrent crashes upon launch

doverosx at gmail.com doverosx at gmail.com
Wed Apr 29 11:35:11 PDT 2009


Kris Moore wrote:
> doverosx at gmail.com wrote:
>   
>> Hello,
>>
>> I've run into this issue, I suspect that there is an issue with the 
>> permissions/PBI installer. I have confirmed that dbus is working (dumped 
>> 75 device when I ran lshal).
>>
>> /<unknown program name>(67804)/: KUniqueApplication: Cannot find the 
>> D-Bus session server
>>
>> <unknown program name>(67803)/: KUniqueApplication: Pipe closed 
>> unexpectedly.
>>
>> Xlib:  extension "Generic Event Extension" missing on display ":0.0".
>> Xlib:  extension "Generic Event Extension" missing on display ":0.0".
>>
>> /Playing around some more, I tried:
>> /
>> [root at pcbsd]/home/Brodey(17)# dbus-launch ktorrent
>> No protocol specified
>> grep: /root/.kde/share/config/kdeglobals: No such file or directory
>> <unknown program name>(43333)/: KUniqueApplication: Cannot find the 
>> D-Bus session server
>>
>> <unknown program name>(43332)/: KUniqueApplication: Pipe closed 
>> unexpectedly.
>>
>> No protocol specified
>> CrashHandler-bin: cannot connect to X server :0
>>
>> /I remember seeing some Xlib errors from another member on the testing 
>> list, but I don't remember the recommended tests/workaround.
>>
>> Regards,
>> Brodey
>>
>>     
>
>
> Brodey,
>
> Does rebooting fix this issue? I've run into a few weird issues with 
> dbus from time to time as well. One thing which seemed to improve it was 
> disabling ntpd. For some reason ntp syncing caused dbus hiccups / 
> timeouts to happen on my system.
>
>
>
>   
Rebooting doesn't seem to fix the issue. I have stopped ntpd, dbus, hald 
and variations of starting/not starting but doing so has no effect on 
ktorrent's access to dbus.

Regards,
Brodey


More information about the Testing mailing list