[PC-BSD Testing] PCBSD 7.1 - can't install gnucash from ports too.

Jeff dejamuse at yahoo.com
Thu Apr 16 06:15:52 PDT 2009


I had this problem with gm4 when installing Webmin into a jail.

I did a 'make deinstall' and 'make reinstall' from ports for m4 and fixed it.  I may also have done the same for autoconf, but don't think it was necessary.

Then just repeated the build of Webmin.

Looks like a package error.

--- On Wed, 4/15/09, doverosx at gmail.com <doverosx at gmail.com> wrote:
From: doverosx at gmail.com <doverosx at gmail.com>
Subject: Re: [PC-BSD Testing] PCBSD 7.1 - can't install gnucash from ports too.
To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
Date: Wednesday, April 15, 2009, 7:11 PM

nr10232 at op.pl wrote:
> error message:
>
> utom4te -B '..'/lib -B '..'/lib         --language M4sh
--cache '' --melt ./autoconf.as -o autoconf.in
> autom4te: need GNU m4 1.4 or later: /usr/local/bin/gm4
> gmake[2]: *** [autoconf.in] Error 1
> gmake[2]: Leaving directory
`/usr/ports/devel/autoconf262/work/autoconf-2.62/bin'
> gmake[1]: *** [all-recursive] Błąd 1
> gmake[1]: Opuszczenie katalogu
`/usr/ports/devel/autoconf262/work/autoconf-2.62'
> gmake: *** [all] Błąd 2
> *** Error code 1
>
> Stop in /usr/ports/devel/autoconf262.
> *** Error code 1
>
> Stop in /usr/ports/lang/guile.
> *** Error code 1
>
> Stop in /usr/ports/finance/gnucash.
> *** Error code 1
>
> Stop in /usr/ports/finance/gnucash.
> [root at pcbsd]/usr/ports/finance/gnucash(3)#
>
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
>
>   
Check for gm4 existing on / ...
/
root at pcbsd# find / -name gm4
/usr/local/bin/gm4
/ 
...interesting.

Update ports....

/root at pcbsd# portsnap fetch; portsnap update


.../install from ports ....

/checking pkg-config is at least version 0.18... 
yes                            
checking for LIBGNOMECANVAS... configure: error: Package requirements (  
gtk+-2.0 >= 2.0.3   gail >= 1.9.0   libart-2.0 >= 2.3.8   pango >= 
1.0.1   pangoft2 >= 1.0.1) were not 
met:                                                           

No package 'gail' found

/Just as I expected, a bunch of stuff related to gnome. Perhaps you can 
copy gm4 from /usr/local/share/examples/gm4.

Regards,
Brodey
/

/

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20090416/cb66d1c5/attachment-0001.html 


More information about the Testing mailing list