[PC-BSD Testing] Ports install of Diablo jre - can't symlink to /usr/local/lib/browser_plugins

Kris Moore kris at pcbsd.com
Fri Apr 3 06:16:13 PST 2009


Jeff wrote:
> Installed FF3.07 from PBI
> Installed Diablo jre-1.6.0 from package, and javamvwrapper from ports.
> Tried to follow directions in FreeBSD handbook for symlinking as follows:
> lnln -s /usr/local/diablo-jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so \
>   /usr/local/lib/browser_plugins/
> 
> The target directory .../browser_plugins doesn't exist.
> Neither does: /PCBSD/local/browser_plugins
> 
> Tried creating these directories and symlinking, but the FF java plugin just doesn't show up.
> 
> I did this before with an earlier version and had no problem.
> 
> Finally just installed Diablo jre from PBI and it worked.
> 
> What changed?  I wanted a ports install so that other ports installed programs
> could find java, like Eclipse.  Once tried to Install Eclipse using jdk instead of jre
> and could never get it to find java.
> 
> 
> ....Jeff
> 
> 

In the PBI to make the java firefox plugins work, we usually link the 
jibjavaplugin_oji.so to the users homedir .mozilla/plugins, thats the 
only place where it seems to reliably function. Can you confirm that it 
shows up if you link to there?

-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list