[PC-BSD Testing] Troubles after updating Skype to 2.0.0.72

Kris Moore kris at pcbsd.com
Wed Apr 1 07:40:31 PST 2009


Eugeniy Khvastunov wrote:
> Hello All!
> 
> Troubles after updating Skype to 2.0.0.72:
> /Programs/Skype2.0.0.72/share/skype/skype: error while loading shared
> libraries: /Programs/Skype2.0.0.72/autolibs/libc.so.6: ELF file OS ABI
> invalid
> Application crashed.
> In /usr/ports/UPDATING I found this:
> 20080318:
>   AFFECTS: users of net/skype net/skype-devel
>   AUTHOR: beech at FreeBSD.org
> 
>   For FreeBSD versions 7.0 and above:
> 
>   It is required with both skype and skype-devel to update to
> linux_base-fc6.
>   Please do the following:
> 
>   1. Make sure there are no running linux applications.
>   2. Unmount linprocfs (umount /compat/linux/proc)
>   3. Uninstall your current linux_base port
>   4. Set appropriate sysctl (sysctl compat.linux.osrelease=2.6.16)
>   5. Install emulators/linux_base-fc6
>   6  Remount linprocfs (mount /compat/linux/proc)
>   7. Add compat.linux.osrelease=2.6.16 to etc/sysctl.conf
>   8. Add OVERRIDE_LINUX_BASE_PORT=fc6 to /etc/make.conf
> 
>   Note: These instructions also apply to linux_base-f8, please use the same
>   osrelease.
> 
>   For FreeBSD versions 5.x and 6.x:
> 
>   Please use the legacy version net/skype12:
> 
>         portupgrade -o net/skype12 net/skype
> 
> May be it's helpfull...
> 
> I using PCBSD 1.5.1
> FreeBSD firefly 6.3-RELEASE-p1 FreeBSD 6.3-RELEASE-p1 #6: Fri Apr 11
> 13:03:49 EDT 2008     root at pcbsd:/usr/obj/usr/src/sys/PCBSD  i386
> 

Thanks for the heads up, I'll have to make a new skype1.2 module for 
PC-BSD 1.5.x systems, since thats still on FreeBSD 6.



-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list