[PC-BSD Testing] No launchey after changing DNS

Kris Moore kris at pcbsd.com
Thu Sep 18 07:48:25 PDT 2008


David Reedy Jr wrote:
> Hi all, new to the list.
> 
> I just installed 7.0 release today and I've run into a few problems. 
> I'll send separate emails for each.
> 
> First off, I have a small home network. My FreeBSD 7.0 server runs, 
> among other things, dnsmasq 
> (http://www.thekelleys.org.uk/dnsmasq/doc.html). The way I have it 
> configured, it basically just answers for anything in the hosts file and 
> everything else gets forwarded to my ISP's upstream name servers. 
> Pointing my Windows box at the server has worked fine.
> 
> When I went into Network System Configuration (I think that's what it 
> was called), I changed the DNS servers and changed the host name. After 
> applying the change, no application would launch afterwards. No bouncey 
> cursor, no nothing. I had to reboot the machine. Upon reboot, the host 
> name change remained, but the DNS servers had reverted back to the 
> upstreams, and I was able to launch applications again.
> 
> Any ideas?


That is really strange! Did you see any errors or anything when the 
system started acting up? Also, do you have your network setup with 
DHCP? If so, you'll need to assign a static IP address before using a 
specific DNS, otherwise the DHCP values will override any specified DNS 
each time. You can manually check the DNS by looking at /etc/resolv.conf 
also BTW.

--
Kris Moore
PC-BSD Software



More information about the Testing mailing list