[PC-BSD Testing] Networked Printers

Bill Leeper protagonist at charter.net
Fri Sep 12 17:57:09 PDT 2008


OK, I redid everything and it seems to be working now. Must be the  
"ghost in the machine". What really had me puzzled was that T-Bird  
worked just fine.


Sorry about that Kris.
On Sep 12, 2008, at 5:19 PM, Ian Robinson wrote:

> Bill Leeper said:
>
> . . .  on the subject of printing:
>
> Either I am doing something wrong or the fix does not work. After
> applying the fix trying to print will now crash Firefox. Before it
> just did not print.
>
> Having done a bit more checking the fault seems to be that I don't
> have a LPR, but rather a network laser.
>
>
>
> Bill -- I have networked printers (HP LaserJets 4, 4Si, 5Si, 5C) all
> set to a fixed TCP/IP address of course and I use the CUPS interface.
> Up through the release of Firefox 2.xx things had worked perfectly.
> With the Firefox 3 upgrade, the printing dialog defaults to a "lpr"
> command. Attempts to print crash and close Firefox.  If I replaced the
> "lpr" command with either a "kprinter" command or a
> "/usr/local/bin/lp" command, I could print. However, that requires
> that I enter the command each time, click OK, wait an almost
> unbearable amount of time for a second print dialogue window to come
> up, and click through yet another OK button.
>
> Kris' fix makes things work great with networked printers that use
> CUPS.  I wonder what kind of printer you have and how it is
> configured?
>
>
> Ian Robinson
> Salem, Ohio
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing


Computers can be fun again
                 format C:\
   Alternatives are out there




More information about the Testing mailing list