[PC-BSD Testing] PC-BSD 7 Beta 1 newbie comments

Mark Daniel mark.daniel at wasd.vsm.com.au
Wed Sep 3 07:53:47 PDT 2008


I have been using PC-BSD as a *desktop* (i.e. not a power-user or developer)
since Jan'08 after moving from XP (for a range of reasons, none of which were
experienced instability).

I'm providing these comments in the hope they may be helpful but am not
familiar with providing appropriate technical detail on a U*x platform so
please bear with me.  Installed x86 from the *DVD* ISO (excellent!) on a
separate disk to my PC-BSD 1.5.1.

A dmesg snapshot:

|FreeBSD 7.0-STABLE #37: Mon Aug 25 13:36:21 EDT 2008                     
|   root at pcbsd:/usr/obj/usr/src/sys/PCBSD                                
|Timecounter "i8254" frequency 1193182 Hz quality 0                       
|CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 6400+ (3214.65-MHz 686-class CPU)
|real memory  = 3488481280 (3326 MB) 
|avail memory = 3400851456 (3243 MB)

Installed the BETA last Saturday and after the initial culture shock of KDE
4.n am settling-in reasonably well.  When installing PBI I have ensured I
have 7.0-specific releases.  Much of the basics are available, sound, video,
network, Skype.  Took a while to discover the 'system tray' widget.  Although
I seem to have spent most of my time wrapping my head around KDE 4 I have
also noticed these (so far) ...

1) I cannot get KTorrent to appear in that system tray.  It is running but
seems inaccessable.  From the shell:

|[mark at gort /usr/home/mark]$ ktorrent
|kdevelop (core): [virtual void DDockWindow::addWidget(const QString&,
QWidget*,bool)]

2) My NVIDIA is performing *much* better using the 177.70 BETA driver.

|vgapci0: <VGA-compatible display> port 0xdf00-0xdf7f mem
\>|0xfa000000-0xfaffffff,0xd0000000-0xdfffffff,0xf8000000-0xf9ffffff irq 18
at device 0.0 on pci1         
|nvidia0: <GeForce 8600 GT> on vgapci0

|vgapci0: child nvidia0 requested pci_enable_busmaster

|vgapci0: child nvidia0 requested pci_enable_io

|nvidia0: [GIANT-LOCKED]

|nvidia0: [ITHREAD]


3) K3b is causing some grief.  It *eventually* tells me that it cannot find
any burner.  It's a SATA.  The k3b splash-image also blocks.  I have found
some k3b instructions for FreeBSD 7.0 involving the short-cut of running as
root which I have used without success.  For a turn-key environment such as
PC-BSD such contortions for commodity burner functionality are
counter-intuitive.

|[mark at gort /usr/home/mark]$ su root -mc /usr/local/bin/k3b           
|Password:                                                            
|Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
|kbuildsycoca running...
|Reusing existing ksycoca

|kbuildsycoca: WARNING: '/usr/local/kde4/share/applications/kde4/ark.desktop' specifies undefined mimetype/servicetype 'application/x-compressed-tar'
8< snip 8<
|(K3bDevice::openDevice) open device /dev/pass5 succeeded.

|(K3bDevice::openDevice) open device /dev/pass5 succeeded.

|(K3bDevice::ScsiCommand) transport command 5a, length: 10

|(K3bDevice::ScsiCommand) transport failed (4): 336896

|(K3bDevice::ScsiCommand) failed:

|                           command:    MODE SENSE (5a)

|                           errorcode:  70

|                           sense key:  ILLEGAL REQUEST (5)

|                           asc:        24
|                           ascq:       0
|(K3bDevice::Device) /dev/cd0: MODE SENSE length det failed.
|(K3bDevice::ScsiCommand) transport command 5a, length: 10
|(K3bDevice::ScsiCommand) transport failed (4): 336896
|(K3bDevice::ScsiCommand) failed:
|                           command:    MODE SENSE (5a)
|                           errorcode:  70
|                           sense key:  ILLEGAL REQUEST (5)
|                           asc:        24
|                           ascq:       0
|(K3bDevice::Device) /dev/cd0: MODE SENSE with real length 65535 failed.
|(K3bDevice::Device) /dev/cd0: modeSense 0x05 failed!
|(K3bDevice::Device) /dev/cd0: Cannot check write modes.
|(K3bDevice::ScsiCommand) transport command 5a, length: 10
|(K3bDevice::ScsiCommand) transport command 5a, length: 10
|(K3bDevice::ScsiCommand) transport command 0, length: 6
|(K3bDevice::ScsiCommand) transport failed (4): 145921
|(BSDDeviceScan) periph: cd1
|(BSDDeviceScan) periph: pass6
|(BSDDeviceScan) add device /dev/cd1:6:0:0 (/dev/pass6)
|(K3bDevice::Device) /dev/cd1: init()
|^C[1] 19872

>From dmesg:

|atapci0: <ATI IXP600 SATA300 controller> port
\>|0xff00-0xff07,0xfe00-0xfe03,0xfd00-0xfd07,0xfc00-0xfc03,0xfb00-0xfb0f mem
0xfe02f000-0xfe02f3ff irq 22 at device 18.0 on pci0
|atapci0: [ITHREAD]
|atapci0: AHCI Version 01.10 controller with 4 ports detected
|ata2: <ATA channel 0> on atapci0
|ata2: [ITHREAD]
|ata3: <ATA channel 1> on atapci0
|ata3: [ITHREAD]
|ata4: <ATA channel 2> on atapci0
|ata4: [ITHREAD]
|ata5: <ATA channel 3> on atapci0
|ata5: [ITHREAD]
8< snip 8<                                                                
|ad0: 76318MB <Seagate ST380021A 3.75> at ata0-master UDMA100
|acd0: DMA limited to UDMA33, device found non-ATA66 cable
|acd0: DVDROM <DVD-ROM BDV316G/VER 0019> at ata0-slave UDMA33
|ad1: 305244MB <WDC WD3200AAKS-00YGA0 12.01C02> at ata2-master SATA300
|GEOM_LABEL: Label for provider ad0s1 is ntfs/DVDS.
|ad2: 305245MB <WDC WD3200AAJS-00RYA0 12.01B01> at ata3-master SATA300
|acd1: DVDR <PIONEER DVD-RW DVR-215/1.19> at ata5-master SATA150
|GEOM_LABEL: Label for provider ad0s5 is ntfs/DVD.
|acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
|acd1: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 sks=0x48 0x00
0x01
|cd0 at ata0 bus 0 target 1 lun 0
|cd0: <DVD-16X DVD-ROM BDV316G 0019> Removable CD-ROM SCSI-0 device
|cd0: 33.000MB/s transfers
|cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
|da0 at umass-sim0 bus 0 target 0 lun 0
|da0: <Generic 2.0 Reader   -CF 1.00> Removable Direct Access SCSI-0 device
|da0: 40.000MB/s transfers 
|da0: Attempt to query device size failed: NOT READY, Medium not present 
|SMP: AP CPU #1 Launched!
|cd1 at ata4 bus 0 target 0 lun 0
|cd1: <PIONEER DVD-RW  DVR-215 1.19> Removable CD-ROM SCSI-0 device 
|cd1: 3.300MB/s transfers 
|cd1: Attempt to query device size failed: NOT READY, Medium not present

4) I attempted to [Install New Widgets] from the Internet.  It presents
Crystal Monitor and Piconet and reports successful install (and now
'uninstall') but I cannot see the 'plasmoids' to actually [Add Widget] them
to the plasma task-bar.

5) The Firefox from the PBI has text slider-bar issues.  The [Install
scrollbar fix] from 'GTK Styles and Fonts' seems to have contributed nothing.
Of course as no other application tried (including other browsers and Win32
Firefox) exhibits this, it is perhaps a native Firefox issue.

All-in-all, remarkably functional for a BETA!  Thanks for something not-L*x.

Of course I hope this is of some use towards polishing the final release,
Mark.


More information about the Testing mailing list