[PC-BSD Testing] Testing Digest, Vol 21, Issue 23

Ian Robinson fitchkendall at gmail.com
Tue Oct 21 13:52:34 PDT 2008


1.  Root in Terminal.  I second Drache's report concerning terminal
having the root prompt all the time.

2.  OpenOffice MIA in PCBSD 7.0.1 and 1.5.1.  I also had the same
experience others "losing" OpenOffice after the upgrade from i386 7.0
to 7.0.1.  Same effect on the OpenOffice upgrade in PCBSD 1.5.1.
OpenOffice is not being found on the menu, on the Desktop, or with the
search function.

3.  Lost Desktop Icons after changing desktop background in 7.0.1.
After changing the Desktop background from Fibonacci default to
anything else, I lose the icons and the icon text.  This is not a lack
of contrast like blue-on-blue or white-on-white problem.  The icons &
text come back after a while but then disappear after bringing
something else over the desktop.  It's like it takes Plasma several
minutes to redraw them.

4.  Improve System Administration Function-- Since everything done
with the GUI system administrator requires the root password, it would
be a great improvement to enter it once upon starting the program like
it was in PCBSD 1.x.  As it is now, you get an intro screen where you
must click to start the administrator mode, enter your password, open
a new window, do a second task, enter your password, etc.  Same
problem with network configuration.  You have to constantly re-enter a
password to perform any of the several modules in the program.



On Tue, Oct 21, 2008 at 3:00 PM,  <testing-request at lists.pcbsd.org> wrote:
>   1. 7.01 Stuff (DragonFlier)
>   2. Re: Patch 7.0.1 Live! (Rod Clark)
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 20 Oct 2008 22:26:29 -0700
> From: DragonFlier <dracheflieger at gmail.com>
> I can't live with the new konsole prompt. The hash mark means you are root.
> Having it there all the time just doesn't work for me.
>
> Installed the system update first, then the two PBIs. They are MIA. No
> results in the Menu Updating Tool nor do they exist in the Programs folder
> or the Software Add/Remove. This is the result of a find for opera
>
>  92117        3 drwxr-xr-x    2 root             wheel                   3
> Sep  7 08:35 /usr/local/lib/npapi/symlinks/opera
> 459803        3 drwxr-xr-x    3 root             wheel                   7
> Oct 16 05:46 /usr/ports/www/opera
> 193632        1 lrwxr-xr-x    1 root             wheel                  31
> Sep 16 12:19 /usr/Programs/bin/opera -> /Programs/Opera9.52/.sbin/opera
>
> System Settings (Administrator) the text under _some_ of the icons disappear
> when hovering...errr...they did...but I just checked again and now they
> don't!?
>
> --
> Drache - is still walking above ground and traveling between eternities -
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: http://lists.pcbsd.org/pipermail/testing/attachments/20081020/73db0a2c/attachment-0001.html
>
> ------------------------------
>
> Message: 2
> Date: Tue, 21 Oct 2008 08:54:00 +0000 (UTC)
> From: Rod Clark <sc at sdf.lonestar.org>
> Subject: Re: [PC-BSD Testing] Patch 7.0.1 Live!
> To: PC-BSD Testing list <testing at lists.pcbsd.org>
> Message-ID:
>        <alpine.NEB.1.10.0810210822360.15633 at faeroes.freeshell.org>
> Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
>
> Aaron wrote:
>> I updated the PBI's this morning, including Openoffice.  Later I saw the
>> system update and did that.  After restart I have lost Openoffice from
>> the program list and is gone from installed PBI Software(KDE control module)
>> Tried the menu updating tool and it didn't find Openoffice either.
>> In the programs folder, it looks like Openoffice has been removed.
>
> Kris,
>
> That happened with the new OpenOffice 3.0 PBI for v1.5.1, too.
> So it's not specific to v7.
>
> After I manually downloaded it from pbidir.org, it installed
> normally by clicking on it in Konqueror. But something is screwy
> with the new OOo 3.0 PBI for v1.5.1. The first file I opened was
> a long .txt file. Writer insisted on opening it in Calc, not in
> Writer itself, and I could find no way around this.
>
> This PBI update didn't allow keeping my known good installation
> of 2.4.0 alongside the buggy new PBI. I uninstalled 3.0.0 and
> reinstalled 2.4.0, which read in the .txt file just fine.
>
> In the PBI system, it would be a welcome improvement to always
> allow the option of installing the new version without wiping
> out the current working version. Later, after the new version
> proves to be an improvement, it's easy enough to delete the old
> version at leisure with the Add/Remove Programs menu tool.
>
> PBI packagers need to step back a bit from trusting that their
> pet app is going to work flawlessly in a new release, and
> blithely proceed to destroy the old one. Some of these apps are
> barely alpha releases. And the basic idea of PBIs is to isolate
> people from inadvertently screwing up a working installation
> while upgrading.
>
> -rsc
>
>
> ------------------------------
>
> Message: 3
> Date: Tue, 21 Oct 2008 10:59:35 -0400
> From: Kris Moore <kris at pcbsd.com>
> Subject: Re: [PC-BSD Testing] Patch 7.0.1 Live!
> To: PC-BSD Testing list <testing at lists.pcbsd.org>
> Message-ID: <48FDEE57.6000808 at pcbsd.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Walt Pawley wrote:
>> At 11:11 AM -0500 10/20/08, Aaron Sloan wrote:
>>> I updated the PBI's this morning, including Openoffice.  Later I saw the
>>> system update and did that.
>>
>> I haven't had my PC-BSD 7 64-bit up for a while, but decided
>> today would be a good day to give the update a go since, from
>> what the list has been reporting, an update was available. Upon
>> firing the machine up, I encountered an immediate setback,
>> probably just from my naivete: it wouldn't mount the root file
>> system.
>>
>> I'd been playing with something else that involved sticking an
>> IDE hard drive in the box since I had PC-BSD 7 up last.
>> Apparently, the boot code remembers the text of some previous
>> boot as the place to get the root of the file system. By adding
>> the hard disk, the device numbers were all advanced by one. So
>> I tried ufs:ad03s1a as was indicated might be the right thing
>> to do. It simply reprompted me with the choices. So, I tried
>> ufs:/dev/ad03s1a and that worked just fine.
>>
>> Once at the desktop, I was expecting the Update Manager to tell
>> me there was an update available. Nada. I told it to go look.
>> Still nothing. So, I'm in the process of downloading the DVD
>> image for 7.0.1.
>>
>> Did I misinterpret the email and the announcement web page?
>> They seem to indicate that the ISO was not yet ready but the
>> system update process was. ???
>
> Walt, the 7.0.1 online update is for 7.0 i386 systems. 7.0.1 is the
> first official amd64 release, so you'll have to grab the ISO for it.
> It'll be supported by patches in the future though :)
>
>
> --
>
> Kris Moore
> PC-BSD Software
> http://www.pcbsd.com
>
>
> ------------------------------
>
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
>
>
> End of Testing Digest, Vol 21, Issue 23
> ***************************************
>


More information about the Testing mailing list