[PC-BSD Testing] Alpha 4 package problems

Kris Moore kris at pcbsd.com
Mon Jul 21 07:43:48 PDT 2008


wa5qjh wrote:
> Kris:
> I just installed new Alpha #22 and the install went very nicely, KDE 
> seems to be doing fine and tried the ATI driver with 3D support. That 
> seems to be working ok.I started having problems whn open office and 
> Koffice apparently did not install, so tried from the Download PBIs. OO 
> would not install from there so went to the URL you 
> gave:pbibuild.pcbsd.org/....sort=date.. tried that. several packages 
> would not load, K3B,openoffice, Thunderbird all complaining of corrupt 
> files. However, Skype, Putty,, wireshark, gkrellm2. did install nicely. 
> even WinFirefox3 installed bu could not run it as a user without 
> changing ownerships of Programs/WinFirefox-3/WINFF (chown -R User:User).
>  Needing an email client, I went to /usr/ports which had been installed, 
> and tried make search name=thunderbird which as been failing since #20, 
> requiring "make fetchindex". simply "make index" fails quickly. after 
> finding the thunderbird directory, tried "make install clean". This has 
> worked on at least #20 and #21 but not now. THe following is 
> representative of soome three or four ports I tried:
> 
>  ===>   thunderbird-2.0.0.14_1 depends on executable: zip - found
> ===>   thunderbird-2.0.0.14_1 depends on executable: gmake - not found
> ===>    Verifying install for gmake in /usr/ports/devel/gmake
> ===>   Returning to build of thunderbird-2.0.0.14_1
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/printproto.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/sm.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/xt.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/xi.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/xext.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/x11.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/xinerama.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/ice.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/libdata/pkgconfig/xproto.pc - found
> ===>   thunderbird-2.0.0.14_1 depends on file: /usr/local/bin/perl5.8.8 
> - found
> ===>   thunderbird-2.0.0.14_1 depends on file: 
> /usr/local/bin/intltool-extract - found
> ===>   thunderbird-2.0.0.14_1 depends on executable: pkg-config - found
> ===>   thunderbird-2.0.0.14_1 depends on executable: 
> update-desktop-database - found
> ===>   thunderbird-2.0.0.14_1 depends on shared library: cairo.2 - found
> ===>   thunderbird-2.0.0.14_1 depends on shared library: jpeg.9 - found
> ===>   thunderbird-2.0.0.14_1 depends on shared library: nspr4 - not found
> ===>    Verifying install for nspr4 in /usr/ports/devel/nspr
> ===>  Building for nspr-4.7
> env: gmake: No such file or directory
> *** Error code 127
> 
> Stop in /usr/ports/devel/nspr.
> *** Error code 1
> 
> Stop in /usr/ports/mail/thunderbird.
> 
> Again, in the previous Alphas, making the ports has worked pretty good 
> so something has definitly gone wrong. I probably should know how to 
> correct that "make" problem, but I dont. I did try to make gmake and 
> nspr but that failed too. I've been especially dissapointed in not 
> having K3B as that has worked in Alpha #20 but not 21 or 22.
> Gary Corell

I'll investigate this a bit. It soulds like gmake is leaving some files 
behind which make it "think" its installed, but when it goes to use it, 
it fails. You can always do pkg_add -r gmake to add it manually and get 
your builds working in the meantime.


-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list