[PC-BSD Testing] Follow-up 7.0 Alpha 3 and wifi iwi driver

Ian Robinson fitchkendall at gmail.com
Fri Jul 18 21:11:30 PDT 2008


Follow-up on laptop Intel PRO/2200 B/G Wireless Network Card "iwi"



1.  Dmesg output:

  ieee80211_load_module: load the wlan_scan_sta module by hand for now.

  ieee80211_load_module: load the wlan_scan_sta module by hand for now.

  ifconfig: on: bad value



2.  I notice that the wlan_scan_sta message occurs twice.

  Is that because /boot/loader has two occurrances of
legal.intel_iwi.license_ack=1 ?

  ------------------Excerpt from Loader File-------------------------

  legal.intel_iwi.license_ack=1
  legal.intel_wpi.license_ack=1
  wlan_scan_sta_load="YES"
  wpi_load="YES"
  -----------------------------------------------------

3.  Status of iwi0 after boot:

  iwi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

        ether 00:0e:35:67:76:1e
	media: IEEE 802.11 Wireless Ethernet autoselect
	status: no carrier

	ssid wepmode channel 1 (2412 Mhz 11b)

	authmode OPEN privacy OFF bmiss 10 scanvalid 60 bgscan

	bgscanintvl 300 bgscanidle 250 roam:rssi11b 7 roam:rate11b 1 bintval 0


4.  Xterm Command line arguments issued:

  ifconfig iwi0 inet 192.168.2.20 netmask 0xffffff00 ssid W2a8u6g4h4
wepmode on wepkey 0x0102030405 weptxkey 1


5.  Status of iwi after command line arguments:

  iwi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

	ether 00:0e:35:67:76:1e
	inet 192.168.2.20 netmask 0xffffff00 broadcast 192.168.2.255
	media: IEEE 802.11 Wireless Ethernet autoselect
	status: no carrier

	ssid W2a8u6g4h4 channel 1 (2412 Mhz 11b)

	authmode OPEN privacy ON deftxkey 1 wepkey 1:40-bit bmiss 10

	scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi11b 7

	roam:rate11b 1 bintval 0


Ian Robinson
Salem, Ohio


More information about the Testing mailing list