[PC-BSD Testing] Follow-up -- iwi driver, etc. (Testing Digest, Vol 18, Issue 18)

Ian Robinson fitchkendall at gmail.com
Fri Jul 18 17:52:16 PDT 2008


1.  iwi wireless driver:

Kris said:

The iwi driver should be included by default, along with the firmware.
If you go into "system-settings" then Network Configuration, can you see
a wireless device and scan for your SSID? This was working previously.
= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =

Yes, Kris, in 7.0 Alpha 3 I can see a wireless device correctly
identified as iwi0, but the scanning for my SSID does not work.  The
scan window reports "No wireless networks found!" even when I am only
three feet from the wireless router.  In contrast, under 7.0 Alpha 1
everything auto-detected (except my security key of course) and could
be read all over the house.

My comments in Vol 18, Issue 18 about missing firmware is because 7.0
Alpha 3 installation does not have the iwi files that 1.5.x and
earlier versions had.  In 1.5.x, the iwi firmware was located in
/boot/firmware and consisted of iwi-boot.fw, iwi-bss.fw, iwi-ibss.fw,
iwi-sniffer.fw, iwi-ucode-ibss, iwi-ucode-sniffer.fw, and LICENSE.iwi.
 However, I notice that /boot/loader.conf does have an entry to
acknowledge the iwi license.

I'll research more, and reinstall Alpha 1 if necessary, to learn why
the difference between Alpha 1 and Alpha 3.

= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =
2.  Black Screen/White Square Freeze up

I said:

> 4.  The most unusual problem is that the laptop will freeze at random
> times -- usually after thirty to forty minutes of use.  The screen
> goes black with a 1/4" x 1/4" white square in the upper left corner.
> Sometimes the laptop will reboot on its own at that point.  If the
> laptop does not reboot on its own, keyboard input is useless and the
> laptop just hangs there.  I cannot jump to console or anything else.
> A power-off is required.  I wonder if this is related to KDE 4.1 since
> I did not have that problem under 7.0 Alpha Version 1.

and Kris replied:

Possibly, I'll be uploading a new alpha with KDE 4.1RC1 today, if you
can re-test for this issue hopefully it'll be solved :)

= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =

I will look forward to Alpha 4 and will report.

Thanks Kris,

Ian Robinson,
Salem, Ohio


More information about the Testing mailing list