[PC-BSD Testing] KDE 4 not working

Kris Moore kris at pcbsd.com
Thu Jul 17 06:41:11 PDT 2008


wa5qjh wrote:
> Hi All:
>  My machine is based on an MSI board with Promise Technology bios with 
> 1Gb Ram and 57GB of a 160 GB HD divided into 3 OS's one of which is 
> FreeBSD 6.3 with KDE 3.5.4 running in another partition.
>  Installed 07112008 several times yesterday and today. The installation 
> looks REALLY nice,BTW and went very smoothly except that KDE would not 
> run. Also first time  I tried, I think it was open office failed to install.
>  After the install(s), reboot, and screen resolution selection came KDE 
> starting up, then the login and that's where it broke down. As soon as 
> the password was entered, it tried to enter KDE  showing some kind of 
> splash screen and even played a little noise which quit abruptly. The 
> screen went blank and the KDE Startup screen shoing it starting 
> different parts and then the login again. Tried several if not all the 
> options in the login:
> default: failed
> Custom: not tried
> fluxbox: failed
> KDE:Failed
> /TWM:  WORKED/
> KDE failsafe: failed     not very failsafe, huh? :)
> /failsafe: worked/
>  The indication is that X-Windows is working but for some reason kde 
> just wont.
>  I switched back and forth between my 6.3 installation partition and my 
> test partition but KDE never came up.
> I tried installing with none of the extras like Firefox etc. and as few 
> of the options selected as possible in one instance. no luck
>  I dont know what other information you might need. below is  the top of 
> the dmesg from the 6.3 installation in hopes it might be helpful:
> 
> Copyright (c) 1992-2008 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>         The Regents of the University of California. All rights reserved.
> FreeBSD is a registered trademark of The FreeBSD Foundation.
> FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:18:52 UTC 2008
>     root at dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: Intel(R) Pentium(R) 4 CPU 3.40GHz (3400.14-MHz 686-class CPU)
>   Origin = "GenuineIntel"  Id = 0xf43  Stepping = 3
>   
> Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
>   Features2=0x649d<SSE3,RSVD2,MON,DS_CPL,EST,CNXT-ID,CX16,xTPR>
>   AMD Features=0x20100000<NX,LM>
>   Logical CPUs per core: 2
> real memory  = 1073479680 (1023 MB)
> avail memory = 1037275136 (989 MB)
> ACPI APIC Table: <A M I  OEMAPIC >
> ioapic0 <Version 2.0> irqs 0-23 on motherboard
> bktr_mem: memory holder loaded
> kbd1 at kbdmux0
> ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
> hptrr: HPT RocketRAID controller driver v1.1 (Jan 16 2008 04:16:19)
> acpi0: <A M I OEMRSDT> on motherboard
> acpi0: Power Button (fixed)
> 
>  
> 
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
> 
> !DSPAM:1,487e9a1e20039038315643!
> 
> 


I'm preparing a new Alpha this week with KDE 4.1RC1. Hopefully this it 
has fixed more of these startup bugs / issues. I should have it uploaded 
tomorrow evening sometime. If you continue to run into issues like this, 
we'll need to make sure we report it to bugs.kde.org and ensure they 
know about it, since they are still in a bug fixing phase, and we've 
managed to get several issues resolved already.

For the record, what kind of video card are you using and which driver?

-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list