[PC-BSD Testing] ntfs-3g testing

A.Y. yerenkow at uct.ua
Thu Dec 25 05:59:13 PST 2008


Hello guys, few days ago I built ntfs-3g.5130 under freebsd and start 
some tests.

I called different partition by name of files system there (like ntfs1, 
ntfs2).
Also I have my main ufs partition.

1. Copying

PC-BSD  7.0.2 with manually built 5130
copy 11g file from ntfs1 to ntfs2 - failed at 3611Mb (btw, same size was 
when I tried to copy using ntfs-3g.2310)
copy some 4-7G files from ntfs1 to ntfs2 - failed at somewhere 3+Gb

2. Copying part two
copy 5g file from ntfs1 to ufs - failed at ~ 3600Mb
then, I copied this file by network from ntfs3 (winbox) to ufs
and copied from ufs to ntfs2 - copied fully!
diff file from ufs and copied to ntfs2 said that files different.

but! I took ntfs2, hook it to winbox, compared files, and they are same!
So, I created successfully 5gb file on ntfs, but I couldn't read it 
after 3600 Mb.

It's not memory issue, tried same disk, same OS on two  different PC's. 
- always same results

3. Using ntfs

I mounted 700-mb  iso which on ntfs partition, tried copy files from iso 
- failed on some file, after that no files could be read,
umount md0
try to mount md0 - no such file
ls /dev/md* show file, it exists, and mdconfig succesfully remove it.

copy iso from ntfs to ufs partition, mounted it - all read successfully, 
so this is not iso-related issue, rather ntfs one.


4. Thoughts
I could copy to ntfs big files ok, could watch movies from ntfs 
(probably, didn't had time to start mplayer on 12g file and wait for 
successfull end),
But some copy and random access (like in mounted iso) sometimes fails, 
and it's look like in same places.
As for me - look's like bug in freebsd-patches (which bring 
freebsd-specific read-align to ntfs-3g)




More information about the Testing mailing list