[PC-BSD Testing] USB Mouse and Flash Player not working properly

Casey caseyclaydon at fastmail.com.au
Sun Aug 31 00:33:08 PDT 2008


When I install Beta 1,  the USB Mouse Logitech MX 510 does not get 
detected,  and I have to change it over to another port which then 
works.  And after Beta 1 has been installed,  the mouse does not get 
detected again and have to change it to another port for it to work again.

The Flash Player installed on PC-BSD does not work properly on youtube 
with the video playing with sound but no picture.

The Motherboard is a AM2 Gigabyte GA-MA69GM-S2H,  I have attached the 
diagnostic sheet,



PC-BSD 7-BETA Diagnostic Sheet
Generated: Sun Aug 31 17:28:10 EST 2008

-----------------Dmesg Output-------------------------

Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-STABLE #37: Mon Aug 25 13:36:21 EDT 2008
    root at pcbsd:/usr/obj/usr/src/sys/PCBSD
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ (1904.33-MHz 
686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x60fb1  Stepping = 1
  
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x2001<SSE3,CX16>
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x11f<LAHF,CMP,SVM,ExtAPIC,CR8,Prefetch>
  Cores per package: 2
real memory  = 468582400 (446 MB)
avail memory = 444547072 (423 MB)
ACPI APIC Table: <GBT    GBTUACPI>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <GBT GBTUACPI> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 1bde0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xee00-0xeeff mem 
0xf8000000-0xfbffffff,0xfdfe0000-0xfdfeffff,0xfde00000-0xfdefffff irq 18 
at device 5.0 on pci1
pci1: <multimedia> at device 5.2 (no driver attached)
atapci0: <ATI IXP600 SATA300 controller> port 
0xff00-0xff07,0xfe00-0xfe03,0xfd00-0xfd07,0xfc00-0xfc03,0xfb00-0xfb0f 
mem 0xfe02f000-0xfe02f3ff irq 22 at device 18.0 on pci0
atapci0: [ITHREAD]
atapci0: AHCI Version 01.10 controller with 4 ports detected
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci0
ata4: [ITHREAD]
ata5: <ATA channel 3> on atapci0
ata5: [ITHREAD]
ohci0: <OHCI (generic) USB controller> mem 0xfe02e000-0xfe02efff irq 16 
at device 19.0 on pci0
ohci0: [GIANT-LOCKED]
ohci0: [ITHREAD]
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xfe02d000-0xfe02dfff irq 17 
at device 19.1 on pci0
ohci1: [GIANT-LOCKED]
ohci1: [ITHREAD]
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
ohci2: <OHCI (generic) USB controller> mem 0xfe02c000-0xfe02cfff irq 18 
at device 19.2 on pci0
ohci2: [GIANT-LOCKED]
ohci2: [ITHREAD]
usb2: OHCI version 1.0, legacy support
usb2: SMM does not respond, resetting
usb2: <OHCI (generic) USB controller> on ohci2
usb2: USB revision 1.0
uhub2: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
ohci3: <OHCI (generic) USB controller> mem 0xfe02b000-0xfe02bfff irq 17 
at device 19.3 on pci0
ohci3: [GIANT-LOCKED]
ohci3: [ITHREAD]
usb3: OHCI version 1.0, legacy support
usb3: SMM does not respond, resetting
usb3: <OHCI (generic) USB controller> on ohci3
usb3: USB revision 1.0
uhub3: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered
ohci4: <OHCI (generic) USB controller> mem 0xfe02a000-0xfe02afff irq 18 
at device 19.4 on pci0
ohci4: [GIANT-LOCKED]
ohci4: [ITHREAD]
usb4: OHCI version 1.0, legacy support
usb4: SMM does not respond, resetting
usb4: <OHCI (generic) USB controller> on ohci4
usb4: USB revision 1.0
uhub4: <ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb4
uhub4: 2 ports with 2 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfe029000-0xfe0290ff irq 
19 at device 19.5 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb5: EHCI version 1.0
usb5: companion controllers, 2 ports each: usb0 usb1 usb2 usb3 usb4
usb5: <EHCI (generic) USB 2.0 controller> on ehci0
usb5: USB revision 2.0
uhub5: <ATI EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb5
uhub5: 10 ports with 10 removable, self powered
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci1: <ATI IXP600 UDMA133 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf900-0xf90f at device 20.1 on pci0
ata0: <ATA channel 0> on atapci1
ata0: [ITHREAD]
pci0: <multimedia> at device 20.2 (no driver attached)
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib2: <ACPI PCI-PCI bridge> at device 20.4 on pci0
pci2: <ACPI PCI bus> on pcib2
fwohci0: <Texas Instruments TSB43AB23> mem 
0xfddff000-0xfddff7ff,0xfddf8000-0xfddfbfff irq 22 at device 14.0 on pci2
fwohci0: [FILTER]
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:1a:4d:00:00:e9:cd:00
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:1a:4d:e9:cd:00
fwe0: Ethernet address: 02:1a:4d:e9:cd:00
fwip0: <IP over FireWire> on firewire0
fwip0: Firewire address: 00:1a:4d:00:00:e9:cd:00 @ 0xfffe00000000, S400, 
maxrec 2048
sbp0: <SBP-2/SCSI over FireWire> on firewire0
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0x12b8000
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
re0: <RealTek 8169SC/8110SC Single-chip Gigabit Ethernet> port 
0xde00-0xdeff mem 0xfddfe000-0xfddfe0ff irq 23 at device 15.0 on pci2
re0: Chip rev. 0x18000000
re0: MAC rev. 0x00000000
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 
1000baseT-FDX, auto
re0: Ethernet address: 00:1a:4d:86:a3:85
re0: [FILTER]
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on 
acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
cpu0: <ACPI CPU> on acpi0
powernow0: <PowerNow! K8> on cpu0
cpu1: <ACPI CPU> on acpi0
powernow1: <PowerNow! K8> on cpu1
acpi_button0: <Power Button> on acpi0
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FILTER]
sio0: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 flags 0x10 on 
acpi0
sio0: type 16550A
sio0: [FILTER]
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
pmtimer0 on isa0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
ppbus0: [ITHREAD]
plip0: <PLIP network interface> on ppbus0
plip0: WARNING: using obsoleted IFF_NEEDSGIANT flag
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ppc0: [GIANT-LOCKED]
ppc0: [ITHREAD]
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
uhub1: device problem (TIMEOUT), disabling port 1
Timecounters tick every 1.000 msec
ipfw2 (+ipv6) initialized, divert enabled, nat loadable, rule-based 
forwarding disabled, default to accept, logging disablefirewire0: 1 
nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
d
ad0: 76318MB <MAXTOR STM380215AS 3.AAD> at ata2-master SATA150
acd0: DVDR <HL-DT-ST DVDRAM GH20LS10/FL01> at ata3-master SATA150
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 sks=0x40 0x00 
0x01
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 sks=0x40 0x00 
0x01
SMP: AP CPU #1 Launched!
cd0 at ata2 bus 0 target 0 lun 0
cd0: <HL-DT-ST DVDRAM GH20LS10 FL01> Removable CD-ROM SCSI-0 device
cd0: 3.300MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Trying to mount root from ufs:/dev/ad0s1a
re0: link state changed to DOWN
pcm0: <ATI SB600 High Definition Audio Controller> mem 
0xfe024000-0xfe027fff irq 16 at device 20.2 on pci0
pcm0: [ITHREAD]
pcm0: <HDA Codec: Realtek ALC885>
pcm0: <HDA Driver Revision: 20080420_0052>
pcm1: <ATI (Unknown) High Definition Audio Controller> mem 
0xfdffc000-0xfdffffff irq 19 at device 5.2 on pci1
pcm1: [ITHREAD]
pcm1: <HDA Codec: Unknown Codec>
pcm1: <HDA Driver Revision: 20080420_0052>
re0: link state changed to UP
ums0: <Logitech USB-PS/2 Optical Mouse, class 0/0, rev 2.00/21.00, addr 
2> on uhub0
ums0: 8 buttons and Z dir.

-----------------Messages Output----------------------

Aug 31 17:07:48 pcbsd dhclient: New Broadcast Address (re0): 192.168.1.255
Aug 31 17:07:48 pcbsd dhclient: New Routers (re0): 192.168.1.1
Aug 31 17:07:48 pcbsd kernel: pcm0: <ATI SB600 High Definition Audio 
Controller> mem 0xfe024000-0xfe027fff irq 16 at device 20.2 on pci0
Aug 31 17:07:48 pcbsd kernel: pcm0: [ITHREAD]
Aug 31 17:07:48 pcbsd kernel: pcm0: <HDA Codec: Realtek ALC885>
Aug 31 17:07:48 pcbsd kernel: pcm0: <HDA Driver Revision: 20080420_0052>
Aug 31 17:07:48 pcbsd kernel: pcm1: <ATI (Unknown) High Definition Audio 
Controller> mem 0xfdffc000-0xfdffffff irq 19 at device 5.2 on pci1
Aug 31 17:07:48 pcbsd kernel: pcm1: [ITHREAD]
Aug 31 17:07:48 pcbsd kernel: pcm1: <HDA Codec: Unknown Codec>
Aug 31 17:07:48 pcbsd kernel: pcm1: <HDA Driver Revision: 20080420_0052>
Aug 31 17:07:49 pcbsd kernel: re0: link state changed to UP
Aug 31 17:07:54 pcbsd ntpd[1251]: ntpd 4.2.0-a Sun Aug 24 11:33:02 EDT 
2008 (1)
Aug 31 17:08:36 pcbsd root: Unknown USB device: vendor 0x046d product 
0xc01d bus uhub0
Aug 31 17:08:36 pcbsd kernel: ums0: <Logitech USB-PS/2 Optical Mouse, 
class 0/0, rev 2.00/21.00, addr 2> on uhub0
Aug 31 17:08:36 pcbsd kernel: ums0: 8 buttons and Z dir.
Aug 31 17:08:43 pcbsd sudo:    Casey : TTY=unknown ; PWD=/usr/home/Casey 
; USER=root ; COMMAND=/PCBSD/SystemUpdater/bin/SystemUpdater.sh
Aug 31 17:12:57 pcbsd ntpd[1251]: time reset +0.681152 s
Aug 31 17:25:53 pcbsd ntpd[1251]: kernel time sync enabled 2001
Aug 31 17:26:32 pcbsd su: Casey to root on /dev/ttyp2
Aug 31 17:26:32 pcbsd su: Casey to root on /dev/ttyp2

------------------RC File-----------------------------

background_dhclient="YES"
compat5x_enable="YES"
sshd_enable="YES"
usbd_enable="YES"
moused_type="auto"
moused_enable="YES"
devd_enable="YES"
devfs_system_ruleset="devfsrules_common"
sendmail_enable="NO"
sendmail_rebuild_aliases="YES"
ldconfig_paths="/usr/lib/compat /usr/local/lib /usr/local/kde4/lib 
/usr/local/lib/compat/pkg"

# Enable the pcbsd startup / shutdown scripts
pcbsdinit_enable="YES"
 
#Enable samba server
samba_enable="YES"
 
# Disable LPD  
lpd_enable="NO"
 
# Enable CUPS
cupsd_enable="YES"
linux_enable="YES"
 
# FSCK Enhancements
fsck_y_enable="YES"
background_fsck="NO"
 
# tmpmfs Flags
tmpmfs="YES"
tmpsize="800m"
tmpmfs_flags="-S"
 
# Denyhosts Startup
denyhosts_enable="YES"

# powerd: adaptive speed while on AC power, adaptive while on battery power
powerd_enable="YES"
powerd_flags="-a adaptive -b adaptive" # set CPU frequency

# enable HALd
dbus_enable="YES"
polkitd_enable="YES"
hald_enable="YES"

# Enables support for HPLIP
hpiod_enable="NO"
hpssd_enable="NO"

# ntpdate is deprecated and will eventually be removed from the 
distribution since
# the same functionality is available in ntpd(8).
# Without "ntpd_sync_on_start" option, ntpd refuses to perform an
# initial correction if the clock offset is too large.
#
ntpd_enable="YES"
ntpd_sync_on_start="YES"

# Enable the firewall
pf_rules="/etc/pf.conf"
pf_enable="YES"
pf_flags=""

# Enable ipfw and open it by default since we have PF
firewall_enable="YES"
firewall_type="open"

snddetect_enable="YES"
mixer_enable="YES"
hostname="pcbsd"
ifconfig_re0="DHCP"

------------------Loader File-------------------------

linux_load="YES"
ulpt_load="YES"
#vesa_load="YES"
#splash_pcx_load="YES"
#bitmap_load="YES"
#bitmap_name="/boot/loading-screen.pcx"
hw.ata.atapi_dma="1"
autoboot_delay="5"
kern.ipc.shmseg=1024
kern.ipc.shmmni=1024
legal.intel_iwi.license_ack=1
legal.intel_wpi.license_ack=1
wpi_load="YES"

------------------Free Space--------------------------

Filesystem  1M-blocks Used Avail Capacity  Mounted on
/dev/ad0s1a     73416 4875 62668     7%    /
devfs               0    0     0   100%    /dev
linprocfs           0    0     0   100%    /compat/linux/proc
procfs              0    0     0   100%    /proc
/dev/md0          771    0   709     0%    /tmp

------------------System Processes--------------------

last pid: 13991;  load averages:  0.18,  0.23,  0.23  up 0+00:21:21    
17:28:10
125 processes: 1 running, 124 sleeping

Mem: 190M Active, 141M Inact, 73M Wired, 10M Cache, 53M Buf, 12M Free
Swap: 512M Total, 512M Free


  PID USERNAME    THR PRI NICE   SIZE    RES STATE  C   TIME   WCPU COMMAND
 1738 Casey         1  47    0 64940K 27180K select 0   0:38  4.05% kded4
 1596 root          1  44    0 92716K 61576K select 1   0:39  0.29% Xorg
12925 root          2  96    0 70152K 33192K select 1   0:00  0.29% 
systemsettings
 1793 Casey         4  44    0 82340K 41984K ucond  1   0:00  0.20% plasma
 3983 Casey         6  52    0 99384K 72328K ucond  1   0:11  0.00% 
firefox-bin
 1876 Casey         1  44    0 56128K 22088K select 1   0:04  0.00% kmix
 1897 Casey         1  96    0 60512K 22144K select 1   0:03  0.00% 
NetworkTray
 1764 Casey         1  44    0 52056K 20408K select 1   0:03  0.00% kwin
 1602 haldaemon     1  44    0  6644K  3776K select 0   0:02  0.00% hald
 1780 Casey         1  44    0 74156K 31868K select 1   0:01  0.00% krunner
 1824 root          1  44    0  3264K   904K select 1   0:01  0.00% moused
 1217 root          1   8    0  3460K  1200K wait   0   0:01  0.00% sh
 1923 root          1  44    0 60544K 24336K select 0   0:00  0.00% 
SystemUpdater
 1841 root          1  46    0  5524K  1992K select 0   0:00  0.00% 
hald-addon-mouse-sy
 1779 Casey         1  44    0 38624K 19328K select 1   0:00  0.00% 
nepomukservicestub
 1258 root          1  44    0  3180K   868K select 1   0:00  0.00% powerd
 1953 Casey         1  44    0 66396K 26192K select 1   0:00  0.00% korgac
 1727 Casey         1  44    0 34960K 17092K select 0   0:00  0.00% 
klauncher


More information about the Testing mailing list