[PC-BSD Testing] PCBSD7-x86-08082008 - Laptop Video Problems & System Crashing

Ian Robinson fitchkendall at gmail.com
Mon Aug 11 16:06:44 PDT 2008


This report concerns PCBSD7-x86-08082008 (Alpha #10, August-08-2008)
on a Centrino-based laptop (P4 @ 1.5 GHz, 2Gb RAM, Intel on-board
82855 video chip, sound, and wireless.

I.  LAPTOP INTEL VIDEO SETUP PROBLEM WORSE

This laptop has an on-board Intel 82855 video chip.  The usual
(default) driver for this is "intel".  In the previous two betas, the
video installer would select the "intel" driver by default.  However,
clicking to apply it would fail and continuously loop back to the
video installer selection screen.  If I selected "intel 3d-enable" as
the driver, I could then select the "Apply" button which was accepted.

In the 08-08-2008 Alpha, neither Intel driver works in the video setup
screen.  Both "intel" and "intel 3d-enable" cause a reboot.  Selecting
"vesa" also caused a reboot.  However, clicking "Skip" brings me to a
normal looking desktop.  However, the system is very unstable whenever
it is used.

II. LAPTOP SYSTEM -- FREEZE HISTORY

I have reported a varied history regarding system freezing on this
laptop computer.  The freeze is characterized by the screen
alternately (1) going black except for a small white rectangle in the
upper left corner for one second then (2) displaying the message:

FreeBSD/i386 (pcbsd)(ttyv8)
Login:

Keystrokes were not accepted and one cannot switch to a console.

PCBSD 1.4, 1.4.1, and 1.5 never had that problem.  PCBSD 1.5.1 was the
first release to exhibit either a spontaneous reboot or a freeze and
most of the PCBSD 7 Alphas have exhibited it.  However, such behavior
did not exist on my "plain-vanilla" desktop test platform, an HP
Vectra VL-400, P3 @ 1 GHz, 512 Ram, Matrox G400/G450 Video Adapter.
The contrast between the laptop and the desktop systems prompted Kris
Moore to say:

"Interesting, a freeze / reboot usually indicates some kind of
hardware problem, or a kernel lockup of some type. Does this system
seem stable while running other software? . . .

Kris, here is my reply.  The system has been very stable and never
exhibited freezing or rebooting problems while running the following
operating systems:  PCBSD 1.4, PCBSD 1.4.1, PCBSD 1.5, and PCBSD 7.0
Alpha of 07-18-2008.  The system has been unstable (freezing or
rebooting) on PCBSD 1.5.1 and PCBSD 7.0 Alphas of 07-11-2008,
07-25-2008, 08-02-2008, and 08-08-2008.  The laptop freeze or reboot
problem is the worst in the newest release dated 08-08-08.  See more
on this below.


III.  LAPTOP SYSTEM FREEZE WORSE IN ALPHA #7 (08-08-2008)

1.  Could not fsck corrupted journal.

The system froze and could not be restarted without using the power
button to reboot.  Not surprisingly, after the restart, dmesg reported
that a few blocks of hard disk space were corrupted. The following
error message displayed (where ad0s2a is the PCBSD 7.0 operating
system, ad0s2b is the swap space):

Trying to mount root from ufs:/dev/ad0s2a.journal.
WARNING:  / was not properly dismounted.
Loading configuration files.
kernel dump on /dev/ad0s2b
. . .
Starting file system checks:
/dev/ad0s2a.journal : CANNOT READ BLK:  162207876
/dev/ad0s2a.journal :  UNEXPECTED INCONSISTENCY:  RUN fsck MANUALLY
File system preen failed, trying fsck -y
** /dev/ad0s2a.journal
CANNOT READ BLK 162207872
CONTINUE?  yes
THE FOLLOWING DISK SECTORS COULD NOT BE READ 162207876, ###etc###, ###etc###
/dev/ad0s2a.journal:  CANNOT FIGURE OUT FILE SYSTEM PARTITION
WARNING:  R/W mount of  / denied.  File system is not clean - run fsck
mount:  :  Operation not permitted
Mounting root filesystem rw failed, startup aborted
ERROR:  ABORTING BOOT (Sending SIGTERM to parent)

Since I could not fsck with either the -p or -y option, and because I
could not find how to otherwise fsck a journaled file system, I
reinstalled.

2.  Using common programs causes immediate freeze in Alpha 08-08-2008.

After reinstallation, using Dolphin crashed immediately (tried this 3x
with same result).  Reinstalled PCBSD again as a fresh install.
Reboot and retry Dolphin.  Dolphin crashes immediately.  Reboot &
retry.  Selecting another partition via the Device Added icon crashes
immediately.  Reboot.  Firefox 3 crashed within one minute while
connecting to Google.com.

I was lucky enough to find some additional information after the
screen jumped to ttyv0 blinking "on" (white letters against black
background) and "off" (totally black screen) with this two-step
procedure:  Step 1.   <Ctrl><Alt><F5> took me to a black screen with a
solid white, cursor-like rectangle in the upper left corner.  Step 2.
Using <Ctrl><Alt><F1> returned me to ttyv0 where I could see the
following error messages:

pcbsd kdm_bin IO Error in XOpen Display
pcbsd kdm_bin Display : 0 cannot be opened
pcbsd kdm_bin Unable to fire up local display : 0; disabling.

3.  If you start up but just let the computer run doing nothing, it
appears fine.  The screen savers work and the laptop goes to sleep
without crashing.  I've now had it up for twenty hours and it does not
crash as long as I do nothing with it.  I'll report further after I
try to do something with it.

4.  Do the changes to xorg-server 1.4.2 or the updating to the latest
Intel driver (2.4.0) have anything to do with this behavior.  Kris
mentioned the Intel 2.4.0 upgrade in a reply to Arron Sloan dated
08-11-2008.  I ask about the latter because Aaron's intel 915 chip is
similar to my laptop's video chip.


IV.  WIRELESS NETWORK CARD SUGGESTION FOR NOVICE USERS

I have noticed several people (Gabi Huiber, James T. Nixon III)
comment like I had about their wireless network cards not configuring
automatically and/or their computers "not seeing" the wireless access
point even though in close proximity.  Until this problem is solved
permanently (as it was in PCBSD 1.4.x and PCBSD 1.5.x), my workaround
was to configure my wireless NIC using terminal and the ifconfig
command to pass the commands on to the card. Afterward, I could
connect.

Testers should try ifconfig to see if their wireless card can be
configured under the Alpha.  For those unfamiliar with this method,
you use the terminal, change the user to root using the su command,
and type in the ifconfig commands when you get the # prompt:

Example:  ifconfig iwi0 inet 192.168.2.20 netmask 0xffffff00 ssid
W2a8u6g4h4 wepmode on wepkey 0x0102030405 weptxkey 1

For the unfamiliar, this command line decodes as follows:

"ifconfig" is the basic command
"iwi0" is the name ("iwi") and instance ("0")of my wireless NIC
"inet 192.168.2.20" is the TCP/IP address I assigned
"netmask 0xffffff00" sets the netmask to 255.255.255.0
"ssid W2a8u6g4h4" is the broadcast name of my router
"wepmode on" tells the system I am using wep security
"wepkey 0x0102030405" is the "secret" wep password.  The "0x" is a
prefix.  The rest of the ####s is the "secret" code.
"weptxkey 1" tells the system to use text key #1

Change your arguments to match your card, tcp/ip assignments, etc.  If
your command is complicated, either build a script or save the command
in a text file that you can copy & paste into terminal.

Ian Robinson
Salem, Ohio


>   5. Re: Aug 8 Alpha Wireless Network Scan Fails (Kris Moore)
>   6. Apply / Skip Resolution Setting bug seems fixed with the 08082008 alpha (Arthur Koziol)
>
>
> ----------------------------------------------------------------------
> Message: 5
> Date: Mon, 11 Aug 2008 12:39:11 -0400
> Gabi Huiber wrote:
>> Hello,
>>
>> I have an old Dell Inspiron 2200 laptop with an external Belkin
>> (RaLink, detected as ral0) wireless card. This computer has run PC-BSD
>> 1.4, 1.5 and 1.5.1. Each of those versions upon installation properly
>> scanned my wireless network, found the router, and allowed me to
>> configure the WPA supplicant using the KDE Network Manager. I haven't
>> been so lucky with PC-BSD 7 (08082008). Even if I hold the computer
>> three feet away from the router the scan will fail.
>>
>> My computer now runs PC-BSD 7 alongside PC-BSD 1.5.1, in dual-boot
>> mode. I am writing this from within the PC-BSD 1.5.1 half, and I am
>> connected to the Internet via the same wireless network that PC-BSD 7
>> failed to find. I hope this helps you guys in some way. I am new to
>> alpha-testing.
>>
>> Regards,
>>
>> Gabi
>
> Gabi,
>
> Can you check and confirm if "ifconfig" can scan and see any networks as
> well?
>
> As root:
>
> # ifconfig ral0 up scan
>
> Kris Moore
> PC-BSD Software
> http://www.pcbsd.com
>
>
> ------------------------------
>
> Message: 6
> Date: Mon, 11 Aug 2008 11:20:08 -0500
> From: Arthur Koziol <A-Koziol at neiu.edu>
> Subject: [PC-BSD Testing] Apply / Skip Resolution Setting bug seems fixed with the 08082008 alpha
> All,
>
> Just did a clean install on the 08082008 alpha on my abuse box and it
> now does save the setting when I click the apply button and begin
> loading the desktop. Previous two betas I would click apply and it
> would either fail or just continuously loop back to the Apply / Skip
> screen. Clicking Skip used to get me past this message and to the
> desktop. Woot! Nice job guys.
>>
> ------------------------------
> End of Testing Digest, Vol 19, Issue 17
> ***************************************
>


More information about the Testing mailing list