[PC-BSD Testing] PCBSD 7.0 Alpha (08-02-2008) Bugs

Kris Moore kris at pcbsd.com
Thu Aug 7 13:46:58 PDT 2008


Ian Robinson wrote:
> Dear Kris & PCBSD Development Team:
> 
> This report covers testing of the PC-BSD 7.0 Alpha (08/02/2008) with
> KDE 4.1 Release.  The first section of this report relates to a
> Centrino-based laptop, P4, 1.5 GHz, 2GB RAM, with built-in Intel
> video, sound, and wi-fi.  The second section of this report relates to
> an HP Vectra VL400 desktop computer, PIII 1.0 GHz, 512 MB RAM, with
> video card Matrox G400/G450 (AGP) on vgapci0.
> 
> Part 1.  LAPTOP COMPUTER
> 
> 1.1  Installation.  The laptop installation went well except the video
> card detection phase of the installation which occurs after reboot
> looped repeatedly on the default driver choice ("intel").  More on
> this below.  I like having the added display information that Kris has
> added to this build, and it adds a nice touch to an already impressive
> installer.
> 
> 1.2  Video Detection Phase.  The video detection phase correctly
> detected the monitor model (LG 657), the video card (Intel), and the
> maximum settings for resolution (1024 x 768) and depth (24).  If I
> kept the default installation choice of "intel," I received a KDialog
> message which said, "The previous attempt failed.  Please check your
> settings & try again."  I would then be returned to the video
> detection screen.  The video detection will loop indefinitley if I
> choose the "intel" driver.  However, if I selected "Intel-3D-enable,"
> the detection phase completes normally.


I've already fixed this bug here, was an error in my detection script. 
It'll should be taken care of in the next alpha this week :)

> 1.3  Dolphin still crashes.  I get repeated Signal 11 (SIGSEGV) errors
> while opening directories.  It used to occur only while opening
> directories containing a large count of files.  Now Dolphin seems to
> crash on small directories.  Dolphin crashing is a well-known bug, so
> my guess is it is not related to PC-BSD.

You're right, Dolphin is rather picky still and can crash from 
time-to-time. I would imagine that most users will prefer to default to 
Konq as the file-manager in the meantime.

> 1.4  Opera crashed repeatedly while undertaking any Google search.
> Opera does not crash with Google Gmai.  Konqueror and Firefox played
> nice with Google.

On the latest build here, Opera seems to work fine on any searches. Can 
you re-confirm this after this weeks alpha?

> 1.5  Reboot & Freeze Problem.  The spontaneous freeze or sponaneous
> reboot I had previously reported two or three alphas ago has returned.
>  Either the system reboots spontaneously, or a freeze occurs.  The
> freeze is characterized by the screen alternately (1) going black
> except for a small white rectangle in the upper left corner for one
> second then (2) displaying the message:
> 
> FreeBSD/i386 (pcbsd)(ttyv8)
> Login:
> 
> Keystrokes are not accepted and one cannot switch to a console.


Interesting, a freeze / reboot usually indicates some kind of hardware 
problem, or a kernel lockup of some type. Does this system seem stable 
while running other software?

> Part 2.  DESKTOP COMPUTER
> 
> 2.1 Installation.  The HP intallation went well.
> 
> 2.2  Dolphin crashes frequently with Signal 6 (SIGABRT) while viewing
> directories.  Here is the backtrace:
> 
> Application: Dolphin (dolphin), signal SIGABRT
> [New Thread 0x8102100 (LWP 100178)]
> [Switching to Thread 0x8102100 (LWP 100178)]
> [KCrash handler]
> #6  0x29d691b7 in kill () from /lib/libc.so.7
> #7  0x28e0f137 in raise () from /lib/libthr.so.3
> #8  0x29d67d2a in abort () from /lib/libc.so.7
> #9  0x28c89b95 in qt_message_output () from /usr/local/lib/qt4/libQtCore.so.4
> #10 0x28c89c49 in qFatal () from /usr/local/lib/qt4/libQtCore.so.4
> #11 0x28c89ce5 in qt_assert () from /usr/local/lib/qt4/libQtCore.so.4
> #12 0x28278646 in KDirListerCache::updateDirectory (this=0x82251f0,
>     _dir=@0xbfbfded0)
>     at /usr/ports/x11/kdelibs4/work/kdelibs-4.1.0/kio/kio/kdirlister.cpp:581
> #13 0x28279eb5 in KDirListerCache::slotFileDirty (this=0x82251f0,
>     path=@0xbfbfe0a8)
>     at /usr/ports/x11/kdelibs4/work/kdelibs-4.1.0/kio/kio/kdirlister.cpp:893
> #14 0x2827d5d6 in KDirListerCache::qt_metacall (this=0x82251f0,
>     _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfbfdffc)
>     at kdirlister_p.moc:94
> #15 0x28d749ec in QMetaObject::activate ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #16 0x28d74e22 in QMetaObject::activate ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #17 0x2828e813 in KDirWatch::dirty (this=0x8222420, _t1=@0xbfbfe0a8)
>     at kdirwatch.moc:81
> #18 0x2828ead4 in KDirWatch::setDirty (this=0x8222420, _file=@0xbfbfe0a8)
>     at /usr/ports/x11/kdelibs4/work/kdelibs-4.1.0/kio/kio/kdirwatch.cpp:1661
> #19 0x28290025 in KDirWatchPrivate::emitEvent (this=0x8132fd0, e=0x8236ec4,
>     event=1, fileName=@0xbfbfe0f8)
>     at /usr/ports/x11/kdelibs4/work/kdelibs-4.1.0/kio/kio/kdirwatch.cpp:1142
> #20 0x2829023b in KDirWatchPrivate::slotRescan (this=0x8132fd0)
>     at /usr/ports/x11/kdelibs4/work/kdelibs-4.1.0/kio/kio/kdirwatch.cpp:1220
> #21 0x28293565 in KDirWatchPrivate::qt_metacall (this=0x8132fd0,
>     _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbfe1b8)
>     at kdirwatch_p.moc:72
> #22 0x28d749ec in QMetaObject::activate ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #23 0x28d74e22 in QMetaObject::activate ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #24 0x28daddf7 in QTimer::timeout () from /usr/local/lib/qt4/libQtCore.so.4
> #25 0x28d7d4ee in QTimer::timerEvent () from /usr/local/lib/qt4/libQtCore.so.4
> #26 0x28d73894 in QObject::event () from /usr/local/lib/qt4/libQtCore.so.4
> #27 0x29458afc in QApplicationPrivate::notify_helper ()
>    from /usr/local/lib/qt4/libQtGui.so.4
> #28 0x2945f4be in QApplication::notify ()
>    from /usr/local/lib/qt4/libQtGui.so.4
> #29 0x28619ab3 in KApplication::notify (this=0xbfbfe80c, receiver=0x8132fd8,
>     event=0xbfbfe5ac)
>     at /usr/ports/x11/kdelibs4/work/kdelibs-4.1.0/kdeui/kernel/kapplication.cpp:311
> #30 0x28d64459 in QCoreApplication::notifyInternal ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #31 0x28d8d188 in QTimerInfoList::activateTimers ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #32 0x28d8ae30 in timerSourceDispatch ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #33 0x29e9b096 in g_main_context_dispatch ()
>    from /usr/local/lib/libglib-2.0.so.0
> #34 0x29e9e432 in g_main_context_check () from /usr/local/lib/libglib-2.0.so.0
> #35 0x29e9e9b5 in g_main_context_iteration ()
>    from /usr/local/lib/libglib-2.0.so.0
> #36 0x28d8b4be in QEventDispatcherGlib::processEvents ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #37 0x294dd475 in QGuiEventDispatcherGlib::processEvents ()
>    from /usr/local/lib/qt4/libQtGui.so.4
> #38 0x28d635d3 in QEventLoop::processEvents ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #39 0x28d63761 in QEventLoop::exec () from /usr/local/lib/qt4/libQtCore.so.4
> #40 0x28d6594a in QCoreApplication::exec ()
>    from /usr/local/lib/qt4/libQtCore.so.4
> #41 0x29458097 in QApplication::exec () from /usr/local/lib/qt4/libQtGui.so.4
> #42 0x0808550b in main (argc=6, argv=0xbfbfe964)
>     at /usr/ports/x11/kdebase4/work/kdebase-4.1.0/apps/dolphin/src/main.cpp:94


This backtrace is something you'll want to post over to bugs.kde.org. 
One of the KDE developers will probably be able to look at it, figure 
out what is failing based on the messages above, and hopefully fix it.

> 2.3  Dolphin gemerated a crash with a Signal 6 as I was saving a small
> text file from KWrite.  Neither the system nor KWrite crashed.  I was
> not using the file manager at the time, but I recognize that Dolphin
> is integral to a multitude of operations.  Also, neither Dolphin nor
> Konqueror would let me create a new folder.  In case there were
> privileges issues, I tried to start Dolphin and Konqueror from the
> terminal as the root user with #kdesu Dolphin or #kdesu Konqueror.
> The terminal did not let me start either program.  I was able to
> create the new directory from the command line.
> 2.4  Mounting additional hard disks.  PCBSD mounted without problem a
> 300 Gb internal ide hard drive (ad1) formatted NTFS.  PC-BSD would not
> mount a 500 Gb External USB hard disk.  The external was formatted
> FAT32.  PC-BSD 1.5.x, however, mounts this external without problems.


> I tried the Start menu/Dolphin method of mounting the hard disk (It
> shows up in the "Device Notifier" list of "devices recently plugged
> in" and in the "Computer" tab of the start menu.).  I also tried
> mounting it to /media and /mount via the terminal using #mount_msdosfs
> command with the "-o large" option, but still had no success.  The
> system presented an error message which said:
> 
> An error occurred while accessing 'WD_EXT_500', the system responded:
> org.freedesktop.Hal.Device.Volume.UnknownFailure: Failed to chown
> mount directory"
> 
> Perhaps this information from dmesg will help:
> 
> umass0: <Western Digital External HDD, class 0/0, rev 2.00/0.00, addr
> 2> on uhub0
> da0 at umass-sim0 bus 0 target 0 lun 0
> da0: <WD 5000KS External 101a> Fixed Direct Access SCSI-4 device
> da0: 1.000MB/s transfers
> da0: 476940MB (976773168 512 byte sectors: 255H 63S/T 60801C)
> fsync: giving up on dirty
> 0xc2f05bb0: tag devfs, type VCHR
>     usecount 1, writecount 0, refcount 794 mountedhere 0xc303c800
>     flags ()
>     v_object 0xc1460934 ref 0 pages 20482
>      lock type devfs: EXCL (count 1) by thread 0xc2eda440 (pid 35)
> 	dev ad0s1a.journal
> GEOM_JOURNAL: Cannot suspend file system / (error=35).

This is something that Marcus and the HAL guys will want to know about 
so they can get it fixed in ports:

Take a look here, and please send this info over to them. They usually 
can fix these things fairly quickly.

http://trac.pcbsd.org/wiki/ReportHalBugs

> 2.5  No Reboot or Freeze Problem.  In contrast to the laptop, this
> desktop computer shows no evidence of spontaneous reboot or system
> freeze like that reported in paragraph 1.5 above.

Great! That makes me thing the lockup / freezing problems are something 
hardware / kernel related. I'm still using 7-Stable here, and will 
update it again soon, maybe if its kernel related, it'll be taken care 
of then.

> 2.6 Gwenview --   It is great that Gwenview is the default file
> viewer.  However, the "new" Gwenview 2.x seems crippled in comparison
> to Gwenview 1.4.x because it limits the display height choices and the
> slideshow timing feature will not let you select anything less than 2
> seconds. The new Gwenview seems to get in its own way when in the full
> screen and full screen slideshow modes as it relates to having the
> annoying graphic bar across the top of the screen.  None of this is
> the fault of PC-BSD, but I raise these points hoping that users can
> choose to use Gwenview 1.4.x as the default viewer.
> 
> 2.7  Gwenview #2 + KWrite Cursor -- When the cursor hovers over the
> Gwenview window, it takes on a rectangular shape and looks like a
> barcode.  The same thing happens to the cursor appearance in KWrite
> when I highlight text and drag it to another line.
> 
> 2.8   Help loaded and functioned well.
> 
> 

Thanks very much for the report! Keep sending in any bugs you run across!


-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list