[PC-BSD Testing] Intel XF86 driver with latest Alpha

John Stokes airy at netspace.net.au
Sun Aug 3 16:45:20 PDT 2008


The latest Alpha works with my Intel G35 chipset  :-)  :-) .Interesting 
install though...

When installing I find I still have to set my Sata drives to IDE 
compatible mode to boot the DVD (sata drive) , then when it
has completed the install I can switch back to normal AHCI (native) 
mode.This may be a quirk of the ASUS bios I have ,but it
seems to work with other OS's.

The X config finds the Intel chipset and even loads the config in the 
native (1920x1200) resolution but still only lets me use only up to 
1600x1200 settings - however when I let it set that config it comes up 
with "setting native resolution" and comes up to the full 1920x1200 
desktop .There seems to be a limit of 1600x1200 that trips up both the 
current PC-BSD 1.51 and the alphas??? Looking at the display panel 
1600x1200 is set at auto? (Intel driver works O/K Intel 3D enable driver 
is still nogo)

Again I managed to crash Dolphin within a couple of minutes of using it 
(it still doesn't like accessing my main sata drive (1.51) and looking 
at the Video (no icon) directory) , this is  probably be the biggest 
gripe I have with KDE 4.X because it is critical to everyday usage , I 
had to reboot because Dolphin would no longer load (I couldn't kill the 
process at all). I do see that at KDE Bug Central there is lots of bug 
squashing happening though ...

I was hoping that the PCI info under Kinfo would working by now but alas 
not yet , functionality is now very good though.

K3B still crashes with the pipe message :-(  . But I have Komposer 
running (when the PBI is first run it comes up with a corrupted archive 
integrity  message but when I run it again it works and runs ???)

The Icon/Task bar is now much better size wise  (thanks Kris & Co). The 
mouse acceleration works well at 3 but if the "defaults" button is 
pressed it goes back to 2. :-(

Thunderbird didn't put an icon in the menu but did on the desktop (fixed 
with menu editor).

I see a few people having download issues , I noticed that the FTP site 
was being uploaded to slowly Saturday night (Aus time ) so waited till 
all the data was there and my dvd passes its integrity check fine.I have 
in the past transferred the file to a Windows XP machine (Nero) to burn 
though.(I have had dodgy burns with DVDs in the past with K3B - some 
burners aren't liked at all).


John



More information about the Testing mailing list