[PC-BSD Testing] Sun ISO - RC2 Problems on portable with video resolution and wireless.

Ian Robinson fitchkendall at gmail.com
Sun Sep 16 14:39:44 PDT 2007


The Sunday build worked flawlessly on an HP Vectra VL400 desktop, but I had
two significant problems running on a laptop.  The RC2 build has Xorg 7.3.

Laptop:  Acer TravelMate 4001 with Intel Centrino 1.5 GHz, 2 Gb ram,
Intel 82855 GME SVGA controller, LCD screen
Intel PRO/Wireless 2200BG network interface card ("iwi0")

"Repair/Upgrade" install over a working PCBSD 1.3.4.  This was a failure
because of these problems:

1.  Error message:
After installation, rebooting generated this error message:  KDEInit could
not launch 'dbsd-nettray'.:  could not find 'dbsd-nettray' executable.

2.  Video Resolution Problems.
Attempted to set video resolution to 1280x1024 but it would not hold.  Best
I could get was 1024x768

3.  Wireless Lan Card Problems:
Could not configure wireless lan card (Intel 2200) -- more below.

4.  Shut down freeze.
Shutting down with the Start menu resulted in only a black
screen.Shutting down with a reboot command in terminal produced
beautiful multicolored vertical stripes down the screen.  I
could not progress  past them.  Neither situation responded to
ctrl-alt-delete sequence.  I had to turn the power off resulting in the hard
disk having to perform a lengthy check and repair itself on reboot.


"Fresh Install" worked better and PCBSD works very fast and very well except
issues with Video resolution and the wireless lan card.  So, problems 1 and
4 above were resolved.  However, problems 2 and 3 remained.

2.  Video Resolution Problem remained.
Tried to run configuaration utility without success.  It let me "set"
1280x1024, but it would not hold.  I examined /etc/XII/xorg.conf and saw
that the screen string only had "1024x768" in it.  I manually added
"1280x1024" in the string, but it did not improve the situation.
After a reboot, Xorg reconfigured itself and restored the screen
line with only "1024x768"

The video card is an Intel 8285.
Dmesg shows    agp0: <Intel 82855GME (855GME GMCH) SVGA controller> port
0x1800-0x1807 etc. etc.
                          agp0:  detected 16252k stolen memory
                          agp0: aperture size is 128M

3.  Wireless Lan Card Problem (Intel PRO/Wireless 2200BG)
The driver is iwi and shows as iwi0 in dmesg.  The significant dmesg report
on this card is:  iwi0:  radio turned off.

/boot/defaults/loader.conf shows the if_iwi_load="NO"
/boot/loader.conf does not list if_iwi_load at all and makes no reference to
any of the wireless related modules

Contents of /boot/loader.conf

     linux_load="YES"
     ulpt_load="YES"
     vesa_load="YES"
     splash_pcx_load="YES"
     bitmap_load="YES"
     bitmap_name="/boot/loading-screen.pcx"
     hw.ata.atapi_dma="1"
     autoboot_delay="5"

but #kldstat shows that iwi_bss.ko is loaded.

the /boot/modules directory includes:
     if_nfe.ko
     iwi_bss.ko
     iwi_ibss.ko
     iwi_monitor.ko
     linker.hints

/etc/rc.conf has this line:
ifconfig_iwi0="DHCP"

The Network Manager shows the card, but does not configure it.

I used iconfig to paste this line:
#iconfig iwi inet 192.168.2.20 netmask 0xffffff00 ssid Myssid wepmode on
wepkey 0xMyWepHexNumbers weptxkey 1
#
#ifconfig iwi0 up scan
SSID      BSSID                       CHAN  RATE      S:0    INT   CAPS
Myssid   00:11:50:21:d9:cc  11       54M      92:0    100  EP    WME


Running #ifconfig iwi0 afterwards shows all things normal except:

status:  no carrier.

I ran:  # dhclient iwi0 resulting in "send_packet:  Network is down"

#ping 192.168.2.1 results in the message:  "ping: sento: Network is down"

#/etc/rc.d/netif start did not change anything.

I am sure that the dmesg iwi0 radio off is important, so I ran
#sysctl dev.iwi.0.radio.1
sysctl:  unknown oid 'dev.iwi.o.radio.1"

I found an interesting analysis at :
http://www.bsdforums.org/forums/showthread.php?t=48251&page=2&pp=15#postmenu_254754
discussing that iwi-firmware for FreeBSD 6.1 had been upgraded for 6.2.  I
think PCBSD has the upgrade installed in /boot/firmware.  However, I noticed
that some of the recommended code for /etc/rc.conf is not in rc.conf, namely
this recommendation:

<snip>
/boot/loader.conf should contain:
if_iwi_load="YES"
wlan_load="YES"
firmware_load="YES"
I also have these, but I do not know if they are still necessary:
wlan_wep_load="YES"
wlan_tkip_load="YES"
wlan_ccmp_load="YES"
wlan_xauth_load="YES"
wlan_acl_load="YES"
<end snip>

None of these lines are in /boot/loader.conf so I will be experimenting with
them.

The last post on PCBSD Forum relating to the Intel Pro 2200 was at
http://forums.pcbsd.org/viewtopic.php?p=58436&sid=c28b2e119e73fb12fe5245e6717492c8
However, I think that post may have related to PCBSD Version 1.3.

USB

Recognized one of my flash (thumb) drives, but would not let me "safely
disconnect" using the Start - System Menu -Storage Media process.
Would not recognize a different flash drive.
Dmesg showed that boot detected my Microsoft Wireless Mouse, but
the mouse did not work.

LAN CARD IMPROVEMENTS

Broadcom BCM4401 (bfe0) worked flawlessly.  I could never get this to work
under 1.3.4 and it would spontaneously reboot the system within seconds of
starting up.  1.3.4 could start with the ethernet cable disconnected, but it
would reboot immediately if it was plugged in.  This is a great improvement
as the BCM4401 is a common card in laptops.


Sincerely yours,

Ian Robinson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20070916/37ea0716/attachment.html 


More information about the Testing mailing list