[PC-BSD Testing] Fwd: 1.4 Beta: Some Observations

Harshad Sharma harshad.sharma at gmail.com
Thu Jul 26 19:06:23 PDT 2007


Dear PCBSD Dev Team,

Here are a few observations regarding the PCBSD Installer and the OS.

=== Installer ===

Screen 1:

   - Timezone: "Asia/Calcutta" has changed to "Asia/Kolkata", we need
to update it.    ( http://en.wikipedia.org/wiki/Calcutta )
   - The installer shows Hindi and Bengali as language options on the
first screen. However on selecting one of these languages, the output
is garbled/ unicode boxes.



   - On changing the language, the options selected on the screen
(timezone etc) are reset (which is not so much of a problem, because
language is expected to be selected first.)
   - Right clicking outside the installer window shows up the fluxbox
menu (again, minor issue), but may confuse total newbies.
   - In the text beside the timezone combo-list box, the word
"synchronization" is lacking an "h"


Screen 2:
   - License, Quick Tips: "...a Unix-like OS for which the license is
named...", I think it should be "after which the license..." instead
of "for".


Screen 4:
   - User Accounts: the new method of password match warning is
unobtrusive - which is great.
   - ""will be logged on automatically" - when we say "login" just
above, can is replace "logged on" with "logged in"?

Drive Selection Screen:
   - 160 GB IDE primary partition not shown. Filesystem is VFAT.
   - On 250 GB SATA, 20 GB is kept for PCBSD testing, rest is
allocated to VFAT... this large partition is also not shown.
   - The 20 GB VFAT partition is shown (which will be erased and
replaced with ufs)

Disk Partitioning Screen:
    - the word "changing" is spelled wrong. (I need to check this
again, because I noted it down sloppily, sorry!)


=== Operating System ===

   - My issues with nVidia GeForce 6200 LE have been resolved. Still
need to check the GeForce 6100 onboard GPU.
   - Graphics drivers selection worked perfectly for me this time.
Previously it included downloading the sources and recompiling the
kernel without the splash driver before I could use the GUI.
   - Beryl works out of the box, which is fantastic!


   - The VFAT issue cropped up again - double clicking on the disk
icon brings up the message "An unexpected error occured" and nothing
more.
   - Even the usual mount command was not working.
   - dmesg was helpful - "Disk too big, try '-o large' mount option.
On adding this option to the mount command, it worked perfectly. Some
software components may need to be updated to reflect this change in
the command.



I still have to work with the OS a bit more to write more, but the
first experience is fantastic. I'm excited about 1.4 release!

Cheers!
Harshad.



--
Harshad Sharma
Photographer.
Ahmednagar, India.
+91 9850 8850 21
http://www.harshadsharma.name


More information about the Testing mailing list