[PC-BSD Testing] 1.4 Beta freezes on Xorg configuration in install

Kris Moore kris at pcbsd.com
Sat Jul 21 12:54:29 PDT 2007


Daniel Sammut wrote:
> Further to my last email.
> 
> I can only get to the desktop if I boot in safe mode. If I try booting
> in normal mode, it gets to either:
> 
> Starting sshd.
> 
> or Starting cron.
> 
> or Local package initialization:.
> 
> or occasionally, login:
> 
> and then it totally freezes. Only a hard-reset can get me back again.
> I then have to login in safe mode. It's not looking good for me, I'm
> afraid.
> 
> On 7/21/07, Daniel Sammut <danielsammut74 at gmail.com> wrote:
>> Okay,
>>
>> Unfortunately, this did not help the Nvidia issue. I still get the exact
>> same freeze when trying to configure X after install. I then boot into safe
>> mode and I tried the 100.14.11, 9746 and the 7184 drivers all without
>> success - only the 'nv' one works.
>>
>> I did notice a couple of error messages while it was trying to start X with
>> the nvidia drivers though, I quickly jotted them down:
>>
>> NVRM: RmInitAdapter failed! (0x12:0x2b:1544)
>> nvidia0: Rm_Init_adapter() failed!
>>
>> I hope you can get some information from that!
>>


Well, the NVRM message helps, You'll want to post this error to the the
NVidia forums, along with the model number of the card:

http://www.nvnews.net/vbulletin/forumdisplay.php?f=47

As for the freezing issue, I'm also concerned by that. It could still be
some sort of ACPI issue, but hard-locking is rather rare. Does the
system work if you pick option 2. Boot with ACPI disabled, instead of
"safe mode"? If so, then we'll need to let the FreeBSD devs know about
this. Here's a good page on this problem, and what information they may
need to get it fixed for your motherboard:

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/acpi-debug.html

There are also some good suggestions on there, about lost interrupts and
how to get info about them.


-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list