[PC-BSD Testing] PCBSD 1.4.1.1 won't update on-line. It quits after 87% of the file download.

Kris Moore kris at pcbsd.com
Wed Dec 5 11:16:24 PST 2007



Jeff,

By default /tmp is using tmpfs, and you should be able to increase the 
space for it by editing rc.conf and looking for this:

tmpmfs="YES"
tmpsize="800m"
tmpmfs_flags="-S"

As for the actual issue with space, thats weird, because when the 
updater runs, it uses "fetch" to download the file to /PCBSD/tmp/ by 
default. In this case, it may be running out of room on "/" possibly. 
You could try linking /PCBSD/tmp to /usr/pcbsdtmp or some other 
directory with more room, and see if that works :)


-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


Jeff Colter wrote:
> PCBSD 1.4.1.1 won't update on-line. It quits after 87% of the file download.
> 
> My /tmp directory had 700MB to play with - shouldn't that be enough for a
> 300MB patch?
> 
> I then tried to symlink /tmp to /var/tmp which is on its own much larger
> partition, but it wouldn't work - guess you can't symlink two existing
> directories.
> 
> Then tried to temporarily delete /tmp to recreate it with  ln -s /var/tmp
> /tmp  so that anything written to /tmp would actually get written to
> /var/tmp.
> 
> Tried to delete or rename /tmp but no go. Even after emptying /tmp it won't
> let me delete it - says "device busy".  It won't let me rename it either,
> since it's a mount point.
> 
> I then gave up and manually updated by downloading the .pbi to my home
> directory which is on /usr/home and is huge, and executed the .pbi from
> there.
> 
> Anyone have a clue why 700MB isn't enough room, or at least know how to
> symlink existing directories?
> 
> Tnx, Jeff
> 
> 
> !DSPAM:1,4756f6b3681491849615612!
> 
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
> 
> 
> !DSPAM:1,4756f6b3681491849615612!


More information about the Testing mailing list