[PC-BSD Testing] evdo KPC650 Wireless Modem Card

Sam Fourman Jr. sfourman at gmail.com
Wed Aug 29 22:22:02 PDT 2007


On 8/25/07, Sam Fourman Jr. <sfourman at gmail.com> wrote:
> hello,
>
> I am Not Sure if this is the right list to post to but,
>
> I have a New KPC-650 Data card (Qualcomm based Device)
> Alltell is my Provider, This Works in Windows and OpenBSD
>
> I am wondering if someone can help me, I am a little confused on what I need
> to do to get PCBSD to get this Working by Default.
>
> I wonder if it would be possible for the Default PCBSD setup to know about
> this device
>
> I do not know if FreeBSD has a umsm driver.
>
>
> if I need to give anyone more info I can... below are Both a PCBSD as well
> as a OpenBSD dmesg
>
> here is a link that I THINK might work in FreeBSD
>
> http://www.semicomplete.com/blog/geekery/Kyocera-KPC650-EVDO-in-FreeBSD.html
>
> dmesg from the latest PCBSD snapshot is:
>
> Copyright (c) 1992-2007 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>     The Regents of the University of California. All rights reserved.
> FreeBSD is a registered trademark of The FreeBSD Foundation.
> FreeBSD 6.2-STABLE #66: Wed Aug 22 11:03:06 PDT 2007
>     root at pcbsd:/usr/obj/usr/src/sys/PCBSD
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: Intel(R) Pentium(R) M processor 1.60GHz (1596.01-MHz 686-class CPU)
>   Origin = "GenuineIntel"  Id = 0x6d8  Stepping = 8
>
> Features=0xafe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,TM,PBE>
>   Features2=0x180<EST,TM2>
>   AMD Features=0x100000<NX>
> real memory  = 1064108032 (1014 MB)
> avail memory = 1028100096 (980 MB)
> ACPI APIC Table: <IBM    TP-75   >
> ioapic0: Changing APIC ID to 1
> ioapic0 <Version 2.0> irqs 0-23 on motherboard
> kbd1 at kbdmux0
> ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
> acpi0: <IBM TP-75> on motherboard
> acpi_ec0: <Embedded Controller: GPE 0x1c, ECDT> port 0x62,0x66 on acpi0
> acpi0: Power Button (fixed)
> Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
> acpi_timer0: <24-bit timer at 3.579545MHz > port 0x1008-0x100b on acpi0
> cpu0: <ACPI CPU> on acpi0
> acpi_perf0: <ACPI CPU Frequency Control> on cpu0
> acpi_throttle0: <ACPI CPU Throttling> on cpu0
> acpi_lid0: <Control Method Lid Switch> on acpi0
> acpi_button0: <Sleep Button> on acpi0
> pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
> pci0: <ACPI PCI bus> on pcib0
> agp0: <Intel 82915GM (915GM GMCH) SVGA controller> port 0x1800-0x1807 mem
> 0xa0080000-0xa00fffff,0xc0000000-0xcfffffff,0xa0000000-0xa003ffff
> irq 16 at device 2.0 on pci0
> agp0: detected 7932k stolen memory
> agp0: aperture size is 256M
> pci0: <display> at device 2.1 (no driver attached)
> pcib1: <ACPI PCI-PCI bridge> irq 20 at device 28.0 on pci0
> pci2: <ACPI PCI bus> on pcib1
> bge0: <Broadcom BCM5750 B1, ASIC rev. 0x4101> mem 0xa0100000-0xa010ffff irq
> 16 at device 0.0 on pci2
> miibus0: <MII bus> on bge0
> brgphy0: <BCM5750 10/100/1000baseTX PHY> on miibus0
> brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT,
> 1000baseT-FDX, auto
> bge0: Ethernet address: 00:16:d3:31:b8:d9
> uhci0: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-A> port
> 0x1820-0x183f irq 16 at device 29.0 on pci0
> uhci0: [GIANT-LOCKED]
> usb0: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-A> on uhci0
> usb0: USB revision 1.0
> uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered
> uhci1: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-B> port
> 0x1840-0x185f irq 17 at device 29.1 on pci0
> uhci1: [GIANT-LOCKED]
> usb1: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-B> on uhci1
> usb1: USB revision 1.0
> uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub1: 2 ports with 2 removable, self powered
> uhci2: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-C> port
> 0x1860-0x187f irq 18 at device 29.2 on pci0
> uhci2: [GIANT-LOCKED]
> usb2: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-C> on uhci2
> usb2: USB revision 1.0
> uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub2: 2 ports with 2 removable, self powered
> uhci3: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-D> port
> 0x1880-0x189f irq 19 at device 29.3 on pci0
> uhci3: [GIANT-LOCKED]
> usb3: <Intel 82801FB/FR/FW/FRW (ICH6) USB controller USB-D> on uhci3
> usb3: USB revision 1.0
> uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub3: 2 ports with 2 removable, self powered
> ehci0: <Intel 82801FB (ICH6) USB 2.0 controller> mem 0xa0040000-0xa00403ff
> irq 19 at device 29.7 on pci0
> ehci0: [GIANT-LOCKED]
> usb4: EHCI version 1.0
> usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
> usb4: <Intel 82801FB (ICH6) USB 2.0 controller> on ehci0
> usb4: USB revision 2.0
> uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
> uhub4: 8 ports with 8 removable, self powered
> uhub5: vendor 0x04b3 product 0x4484, class 9/0, rev 2.00/0.01, addr 2
> uhub5: multiple transaction translators
> uhub5: 3 ports with 3 removable, self powered
> pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
> pci4: <ACPI PCI bus> on pcib2
> cbb0: <RF5C476 PCI-CardBus Bridge> mem 0xa0200000-0xa0200fff irq 16 at
> device 0.0 on pci4
> cardbus0: <CardBus bus> on cbb0
> pccard0: <16-bit PCCard bus> on cbb0
> pci4: <base peripheral> at device 0.1 (no driver attached)
> iwi0: <Intel(R) PRO/Wireless 2915ABG> mem 0xa0202000-0xa0202fff irq 21 at
> device 2.0 on pci4
> iwi0: Ethernet address: 00:16:6f:b0:05:3e
> pci0: <multimedia, audio> at device 30.2 (no driver attached)
> isab0: <PCI-ISA bridge> at device 31.0 on pci0
> isa0: <ISA bus> on isab0
>  atapci0: <Intel ICH6M SATA150 controller> port
> 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1810-0x181f at device
> 31.2 on pci0
> ata0: <ATA channel 0> on atapci0
> ata1: <ATA channel 1> on atapci0
> pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
> acpi_tz0: <Thermal Zone> on acpi0
> atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
> atkbd0: <AT Keyboard> irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> psm0: <PS/2 Mouse> flags 0x1000 irq 12 on atkbdc0
> psm0: [GIANT-LOCKED]
> psm0: model Generic PS/2 mouse, device ID 0
> sio0: configured irq 4 not in bitmap of probed irqs 0
> sio0: port may not be enabled
>  sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
> acpi0
> sio0: type 8250 or not responding
> ppc0: <Standard parallel printer port> port 0x3bc-0x3be irq 7 on acpi0
> ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
> ppbus0: <Parallel port bus> on ppc0
> plip0: <PLIP network interface> on ppbus0
> lpt0: <Printer> on ppbus0
> lpt0: Interrupt-driven port
> ppi0: <Parallel I/O> on ppbus0
> sio1: <Generic IRDA-compatible device> port 0x2f8-0x2ff irq 3 drq 3 on acpi0
> sio1: type 16550A
> sio2 port 0x200-0x207 irq 5 on acpi0
> sio2: type 16550A
> battery0: <ACPI Control Method Battery> on acpi0
> acpi_acad0: <AC Adapter> on acpi0
> pmtimer0 on isa0
> orm0: <ISA Option ROMs> at iomem
> 0xd1000-0xd1fff,0xdc000-0xdffff,0xe0000-0xeffff on isa0
> sc0: <System console> at flags 0x100 on isa0
> sc0: VGA <16 virtual consoles, flags=0x300>
> vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
> ugen0: Broadcom IBM Bluetooth Module, rev 1.10/0.09, addr 2
> ugen1: STMicroelectronics Biometric Coprocessor, rev 1.00/0.01, addr 3
> Timecounter "TSC" frequency 1596008261 Hz quality 800
> Timecounters tick every 1.000 msec
> cardbus0: CIS pointer is 0!
> cardbus0: Resource not specified in CIS: id=10, size=1000
> ohci0: <NEC uPD 9210 USB controller> mem 0xa0203000-0xa0203fff irq 16 at
> device 0.0 on cardbus0
> ohci0: [GIANT-LOCKED]
> usb5: OHCI version 1.0
>  ad0: 57231MB <HTC426060G9AT00 00P3A0B5> at ata0-master UDMA100
> acd0: CDRW <UJDA765 DVD/CDRW/1.70> at ata1-master UDMA33
> Trying to mount root from ufs:/dev/ad0s2a
> usb5: <NEC uPD 9210 USB controller> on ohci0
> usb5: USB revision 1.0
> uhub6: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub6: 1 port with 1 removable, self powered
> cardbus0: CIS pointer is 0!
> cardbus0: Resource not specified in CIS: id=10, size=1000
> ohci1: <NEC uPD 9210 USB controller> mem 0xa0204000-0xa0204fff irq 16 at
> device 0.1 on cardbus0
> ohci1: [GIANT-LOCKED]
> usb6: OHCI version 1.0
> usb6: <NEC uPD 9210 USB controller> on ohci1
> usb6: USB revision 1.0
> uhub7: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub7: 1 port with 1 removable, self powered
> ugen2: Qualcomm, Incorporated Qualcomm CDMA Technologies MSM, rev 1.10/0.00,
> addr 2
> acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 sks=0x40 0x00
> 0x01
> cd0 at ata1 bus 0 target 0 lun 0
> cd0: <MATSHITA UJDA765 DVD/CDRW 1.70> Removable CD-ROM SCSI-0 device
> cd0: 33.000MB/s transfers
> cd0: Attempt to query device size failed: NOT READY, Medium not present -
> tray closed
> pcm0: <Intel ICH6 (82801FB)> port 0x1c00-0x1cff,0x18c0-0x18ff mem
> 0xa0040800-0xa00409ff,0xa0040400-0xa00404ff irq 22 at
> device 30.2 on pci0
> pcm0: <Analog Devices AD1981B AC97 Codec>
> drmsub0: <Intel i915GM>: (child of agp_i810.c) on agp0
> info: [drm] AGP at 0xa0080000 0MB
> info: [drm] Initialized i915 1.5.0 20060119
>
>
> also Here is a OpenBSD -current dmesg
>
> OpenBSD 4.2 (GENERIC) #372: Mon Aug 20 11:27:31 MDT 2007
>     deraadt at i386.openbsd.org
> :/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: Intel(R) Pentium(R) M processor 1.60GHz ("GenuineIntel" 686-class)
> 1.60 GHz
> cpu0:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,TM,SBF,EST,TM2
> real mem  = 1063677952 (1014MB)
> avail mem = 1020870656 (973MB)
> mainbus0 at root
> bios0 at mainbus0: AT/286+ BIOS, date 03/14/06, BIOS32 rev. 0 @ 0xfd750,
> SMBIOS rev. 2.33 @ 0xe0010 (59 entries)
> bios0: vendor IBM version "75ET56WW ( 2.02 )" date 03/14/2006
> bios0: IBM 1869CSU
> apm0 at bios0: Power Management spec V1.2
> apm0: battery life expectancy 29%
> apm0: AC on, battery charge high, charging
> apm0: flags 30102 dobusy 0 doidle 1
>  pcibios0 at bios0: rev 2.1 @ 0xfd6e0/0x920
> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdec0/240 (13 entries)
> pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB ISA" rev 0x00)
> pcibios0: PCI bus #5 is the last bus
> bios0: ROM list: 0xc0000/0xf600! 0xcf800/0x1600 0xd1000/0x1000
> 0xdc000/0x4000! 0xe0000/0x10000
> cpu0 at mainbus0
> cpu0: Enhanced SpeedStep 1600 MHz (1116 mV): speeds: 1600, 1500, 1400, 1300,
> 1200, 1100, 1000, 900, 800, 600 MHz
> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
> pchb0 at pci0 dev 0 function 0 "Intel 82915GM/PM/GMS Host" rev 0x03
> vga1 at pci0 dev 2 function 0 "Intel 82915GM/GMS Video" rev 0x03: aperture
> at 0xc0000000, size 0x10000000
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> "Intel 82915GM/GMS Video" rev 0x03 at pci0 dev 2 function 1 not configured
> ppb0 at pci0 dev 28 function 0 "Intel 82801FB PCIE" rev 0x03
> pci1 at ppb0 bus 2
> bge0 at pci1 dev 0 function 0 "Broadcom BCM5751M" rev 0x11, BCM5750 B1
> (0x4101): irq 11, address 00:16:d3:31:b8:d9
> brgphy0 at bge0 phy 1: BCM5750 10/100/1000baseT PHY, rev. 0
> uhci0 at pci0 dev 29 function 0 "Intel 82801FB USB" rev 0x03: irq 11
> uhci1 at pci0 dev 29 function 1 "Intel 82801FB USB" rev 0x03: irq 11
> uhci2 at pci0 dev 29 function 2 "Intel 82801FB USB" rev 0x03: irq 11
> uhci3 at pci0 dev 29 function 3 "Intel 82801FB USB" rev 0x03: irq 11
> ehci0 at pci0 dev 29 function 7 "Intel 82801FB USB" rev 0x03: irq 11
> usb0 at ehci0: USB revision 2.0
> uhub0 at usb0: Intel EHCI root hub, rev 2.00/1.00, addr 1
> ppb1 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xd3
> pci2 at ppb1 bus 4
> cbb0 at pci2 dev 0 function 0 "Ricoh 5C476 CardBus" rev 0x8d: irq 11
> sdhc0 at pci2 dev 0 function 1 "Ricoh 5C822 SD/MMC" rev 0x13: irq 11
> sdmmc0 at sdhc0
> iwi0 at pci2 dev 2 function 0 "Intel PRO/Wireless 2915ABG" rev 0x05: irq 11,
> address 00:16:6f:b0:05:3e
> cardslot0 at cbb0 slot 0 flags 0
> cardbus0 at cardslot0: bus 5 device 0 cacheline 0x0, lattimer 0xb0
> pcmcia0 at cardslot0
> auich0 at pci0 dev 30 function 2 "Intel 82801FB AC97" rev 0x03: irq 11, ICH6
> AC97
> ac97: codec id 0x41445374 (Analog Devices AD1981B)
> ac97: codec features headphone, 20 bit DAC, No 3D Stereo
> audio0 at auich0
> ichpcib0 at pci0 dev 31 function 0 "Intel 82801FBM LPC" rev 0x03: PM
> disabled
> pciide0 at pci0 dev 31 function 2 "Intel 82801FBM SATA" rev 0x03: DMA,
> channel 0 wired to compatibility, channel 1 wired to compatibility
> wd0 at pciide0 channel 0 drive 0: <HTC426060G9AT00>
> wd0: 16-sector PIO, LBA, 57231MB, 117210240 sectors
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
> atapiscsi0 at pciide0 channel 1 drive 0
> scsibus0 at atapiscsi0: 2 targets
> cd0 at scsibus0 targ 0 lun 0: <MATSHITA, UJDA765 DVD/CDRW, 1.70> SCSI0
> 5/cdrom removable
> cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
> ichiic0 at pci0 dev 31 function 3 "Intel 82801FB SMBus" rev 0x03: irq 11
> iic0 at ichiic0
> usb1 at uhci0: USB revision 1.0
> uhub1 at usb1: Intel UHCI root hub, rev 1.00/1.00, addr 1
> usb2 at uhci1: USB revision 1.0
> uhub2 at usb2: Intel UHCI root hub, rev 1.00/1.00, addr 1
> usb3 at uhci2: USB revision 1.0
> uhub3 at usb3: Intel UHCI root hub, rev 1.00/1.00, addr 1
> usb4 at uhci3: USB revision 1.0
> uhub4 at usb4: Intel UHCI root hub, rev 1.00/1.00, addr 1
> isa0 at ichpcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pms0 at pckbc0 (aux slot)
> pckbc0: using irq 12 for aux slot
> wsmouse0 at pms0 mux 0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> lpt2 at isa0 port 0x3bc/4: polled
> aps0 at isa0 port 0x1600/31
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> biomask eff5 netmask eff5 ttymask fff7
> pctr: 686-class user-level performance counters enabled
> mtrr: Pentium Pro MTRR support
> ohci0 at cardbus0 dev 0 function 0 "NEC USB" rev 0x43: irq 11, version 1.0
> usb5 at ohci0: USB revision 1.0
> uhub5 at usb5: NEC OHCI root hub, rev 1.00/1.00, addr 1
> ohci1 at cardbus0 dev 0 function 1 "NEC USB" rev 0x43: irq 11, version 1.0
> usb6 at ohci1: USB revision 1.0
> uhub6 at usb6: NEC OHCI root hub, rev 1.00/1.00, addr 1
> uhub7 at uhub0 port 1: IBM Hub, rev 2.00/0.01, addr 2
> umsm0 at uhub5 port 1
> umsm0: Qualcomm, Incorporated Qualcomm CDMA Technologies MSM, rev 1.10/0.00,
> addr 2
> ucom0 at umsm0 portno 0
> ugen0 at uhub3 port 1
> ugen0: Broadcom IBM Bluetooth Module, rev 1.10/0.09, addr 2
> ugen1 at uhub3 port 2
> ugen1: STMicroelectronics Biometric Coprocessor, rev 1.00/0.01, addr 3
> dkcsum: wd0 matches BIOS drive 0x80
> root on wd0a swap on wd0b dump on wd0b
>
>
>
Just for records sake, I did get this card to work in PC-BSD 1.4 Beta
This link did the trick (PC-BSD 1.4 is based on FreeBSD 6.2 Stable)
http://www.semicomplete.com/blog/geekery/Kyocera-KPC650-EVDO-in-FreeBSD.html

I would also like to note that EVDO did work in Alltel market 396
I was able to achieve 119 kb's in a 1xEVDO market my ping times to
Google were 200ms

any questions just email me


More information about the Testing mailing list