[PC-BSD Testing] Friday Aug 17 snapshot

Rod Clark sc at sdf.lonestar.org
Mon Aug 20 19:10:06 PDT 2007


Notes from a fresh install of Friday Aug 17 snapshot:

Wrong paths for some apps:

The printer setup wizard didn't work because it couldn't find
cups. ("Unable to restart print server. Error message received
from manager: Unable to find a running CUPS server.") But
actually cupsd was running.

Some PBIs, that I re-installed from a second hard drive after
installing the snapshot, also couldn't start up from their
desktop icons. In these icons' properties, the Command action
appeared as /usr/local/bin/appname, while the Work Path was
/Programs/AppnameDir/appname. After I changed the Command action
to /Program/..., several of these did start up and work
normally. But others continued not to work. These included
GQView, Scribus, Nvu, Audacity, Helix Player and xmms. (Note:
Audacious compiled easily from ports, caused less trouble and is
generally an improvement over xmms.) Other PBIs had no trouble
with any of this.

Network Settings Wizard:

This showed my Atheros 5212 card and scanned for wifi access
points. But there are five of them in the building, and the
wizard limits itself to showing the first 8 characters of each
name. The router I need is one of three that have names that are
the same within the first 8 characters. The other two are named
differently than the first three, but both of them also have the
same first 8 characters. This limitation in the wizard should be
easy enough to fix.

The Network Settings wizard also doesn't show the channel
numbers, which would help in identifying the correct router. The
wizard also displayed the same key string that I used for my
first try (which turned out to be the wrong one), pre-filled in
for me for every one of the others, making it impossible to use
that to identify which one I had tried to configure earlier. The
wizard also doesn't show which access points are operating at
54M or 11M, although ifconfig itself does. It would be helpful
to parrot more of the information from ifconfig onto the wizard
screen.

More USB device woes:

An Eratech EVR-500 digital audio recorder did show up and I was
able to transfer files to and from it. But after I removed it,
the system became unstable after a few minutes.

Plugging in my older digital camera's USB cable almost brought
the system to a standstill. The usual dialog box asking what to
do with a newly recognized device did not appear. When I
unplugged it the system became reponsive again. But Firefox
could no longer open windows, and apps started from desktop
icons would time out and quit instead of coming up. This
required a reboot.

So far I've tried five of my seven USB devices. Two of them
crash/reboot PC-BSD when removed after unmounting, two cause
instability and the other one works fine.

-rsc


More information about the Testing mailing list