<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="top" style="font: inherit;"><div><font class="Apple-style-span" face="arial" size="2"><b>sqlpython writes</b>:</font></div><div><font class="Apple-style-span" face="arial" size="2"><br></font></div><div><font class="Apple-style-span" face="arial" size="2">Hi Kris</font></div><div><font class="Apple-style-span" face="arial" size="2"><b>Intro:</b></font></div><div><font class="Apple-style-span" face="arial" size="2">You may recognize my name as long time forum member and contributor.</font></div><div><font class="Apple-style-span" face="arial" size="2">I have run against a problem with WiFi where I must be over looking something obvious.</font></div><div><font class="Apple-style-span" face="arial" size="2">I have not run PCBSD on a Laptop but Desktop only in the past few versions as I had Dell Laptops with Broadcom Wifi requiring a ndisgen of Win Drivers which would periodically
 Crash..</font></div><div><font class="Apple-style-span" face="arial" size="2"><b>Problem: </b></font></div><div><font class="Apple-style-span" face="arial" size="2"> So.... I now have a Lenovo Thinkpad SL410. which has these NICS</font></div><div><font class="Apple-style-span" face="arial" size="2">re0 (Realtek 8168) which is my Hardwire and works fine</font></div><div><font class="Apple-style-span" face="arial" size="2">wlan0 (Intel Pro/Wireless 5100) which is my Wifi and is THE PROBLEM....</font></div><div><font class="Apple-style-span" face="arial" size="2"> Keep in mind that this is all on a LIVECD as I will not make a Laptop install unless I can resolve my WiFi problem.</font></div><div><font class="Apple-style-span" face="arial" size="2"><br></font></div><div><font class="Apple-style-span" face="arial" size="2"> WiFi is not found automatically but is discovered once I run the GUI System Settings/Configure Network Settings
 .....</font></div><div><font class="Apple-style-span" face="arial" size="2">Next I must choose the Device wlan0 Pro/Wireless and Configure it...</font></div><div><font class="Apple-style-span" face="arial" size="2">I must scan for Wifi Routers which is does and once one is chosen it lights up..</font></div><div><font class="Apple-style-span" face="arial" size="2">I have the FireWall OFF</font></div><div><font class="Apple-style-span" face="arial" size="2">I have shut off all Security..WEP WAP etc.</font></div><div><font class="Apple-style-span" face="arial" size="2">..but no ip address is assigned to wlan0 and yet the correct MAC is listed in ifconfig.</font></div><div><font class="Apple-style-span" face="arial" size="2"><br></font></div><div><font class="Apple-style-span" face="arial" size="2">So of course no connection via Wifi and will not connect nor ping Until GUI Network Settings Config</font></div><div><font class="Apple-style-span" face="arial"
 size="2"><br></font></div><div><font class="Apple-style-span" face="arial" size="2">I have read <b>blog.pcbsd.org/2011/02/possible-fix-for-wireless-freezes/</b></font></div><div><font class="Apple-style-span" face="arial" size="2">..regarding the conflict between devd and netif startup..</font></div><div><font class="Apple-style-span" face="arial" size="2">To test this once the wlan0 had been assigned and configured I reran route -add my gateway which confirmed that it was already in the list and then reran netif script which then connected the wlan0 device to an ip address... </font></div><div><font class="Apple-style-span" face="arial" size="2">I will post the terminal results below from the LIVECD..</font></div><div><font class="Apple-style-span" face="arial" size="2">Hopefully there is a Workaround so I can install to the Laptop other then A hand  config of the Wifi on each Boot and rerunning the netif script each time I need a
 WiFi.</font></div><div><font class="Apple-style-span" face="arial" size="2">** Take Note the Wifi will ping the Router once configured with the Setup both Before and After the netif script is run..but only connect to the Internet addresses after the netif script is rerun...***</font></div><div><font class="Apple-style-span" face="arial" size="2">Thanks for reading.</font></div><div><font class="Apple-style-span" face="arial" size="2"><br></font></div><div><font class="Apple-style-span" face="arial" size="2"><b>***** INFO Below</b></font></div><div><font class="Apple-style-span" face="arial" size="2">pcbsd# route add default 192.168.1.254</font></div><div><font class="Apple-style-span" face="arial" size="2">route: writing to routing socket: File exists</font></div><div><font class="Apple-style-span" face="arial" size="2">add net default: gateway 192.168.1.254: route already in table</font></div><div><font class="Apple-style-span" face="arial"
 size="2">pcbsd# su</font></div><div><font class="Apple-style-span" face="arial" size="2">pcbsd# /etc/rc.d/netif restart</font></div><div><font class="Apple-style-span" face="arial" size="2">wpa_supplicant not running? (check /var/run/wpa_supplicant/wlan0.pid).</font></div><div><font class="Apple-style-span" face="arial" size="2">ifconfig: interface wlan0 does not exist</font></div><div><font class="Apple-style-span" face="arial" size="2">Stopping Network: lo0 iwn0 re0 pfsync0 pflog0 wlan0.</font></div><div><font class="Apple-style-span" face="arial" size="2">lo0: flags=8048<LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384</font></div><div><font class="Apple-style-span" face="arial" size="2">        options=3<RXCSUM,TXCSUM></font></div><div><font class="Apple-style-span" face="arial" size="2">        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 </font></div><div><font class="Apple-style-span"
 face="arial" size="2">        inet6 ::1 prefixlen 128 </font></div><div><font class="Apple-style-span" face="arial" size="2">        nd6 options=3<PERFORMNUD,ACCEPT_RTADV></font></div><div><font class="Apple-style-span" face="arial" size="2">iwn0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290</font></div><div><font class="Apple-style-span" face="arial" size="2">        ether 00:24:d8:00:3e:42</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: no carrier</font></div><div><font class="Apple-style-span" face="arial" size="2">re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500</font></div><div><font
 class="Apple-style-span" face="arial" size="2">        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC></font></div><div><font class="Apple-style-span" face="arial" size="2">        ether 00:76:9e:3c:29:1c</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: Ethernet autoselect (none)</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: no carrier</font></div><div><font class="Apple-style-span" face="arial" size="2">pfsync0: flags=0<> metric 0 mtu 1460</font></div><div><font class="Apple-style-span" face="arial" size="2">        syncpeer: 224.0.0.240 maxupd: 128</font></div><div><font class="Apple-style-span" face="arial" size="2">pflog0: flags=0<> metric 0 mtu 33200</font></div><div><font
 class="Apple-style-span" face="arial" size="2">ifconfig: interface wlan0 does not exist</font></div><div><font class="Apple-style-span" face="arial" size="2">Starting wpa_supplicant.</font></div><div><font class="Apple-style-span" face="arial" size="2">wlan0: no link ...... got link</font></div><div><font class="Apple-style-span" face="arial" size="2">Starting Network: lo0 iwn0 re0.</font></div><div><font class="Apple-style-span" face="arial" size="2">lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384</font></div><div><font class="Apple-style-span" face="arial" size="2">        options=3<RXCSUM,TXCSUM></font></div><div><font class="Apple-style-span" face="arial" size="2">        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 </font></div><div><font class="Apple-style-span" face="arial" size="2">        inet6 ::1 prefixlen
 128 </font></div><div><font class="Apple-style-span" face="arial" size="2">        inet 127.0.0.1 netmask 0xff000000 </font></div><div><font class="Apple-style-span" face="arial" size="2">        nd6 options=3<PERFORMNUD,ACCEPT_RTADV></font></div><div><font class="Apple-style-span" face="arial" size="2">iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290</font></div><div><font class="Apple-style-span" face="arial" size="2">        ether 00:24:d8:00:3e:42</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: associated</font></div><div><font class="Apple-style-span" face="arial" size="2">re0:
 flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500</font></div><div><font class="Apple-style-span" face="arial" size="2">        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC></font></div><div><font class="Apple-style-span" face="arial" size="2">        ether 00:76:9e:3c:29:1c</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: Ethernet autoselect (none)</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: no carrier</font></div><div><font class="Apple-style-span" face="arial" size="2">pcbsd# ifconfig</font></div><div><font class="Apple-style-span" face="arial" size="2">iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290</font></div><div><font class="Apple-style-span" face="arial"
 size="2">        ether 00:24:d8:00:3e:42</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: associated</font></div><div><font class="Apple-style-span" face="arial" size="2">re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500</font></div><div><font class="Apple-style-span" face="arial" size="2">        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC></font></div><div><font class="Apple-style-span" face="arial" size="2">        ether 00:76:9e:3c:29:1c</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: Ethernet autoselect
 (none)</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: no carrier</font></div><div><font class="Apple-style-span" face="arial" size="2">lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384</font></div><div><font class="Apple-style-span" face="arial" size="2">        options=3<RXCSUM,TXCSUM></font></div><div><font class="Apple-style-span" face="arial" size="2">        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 </font></div><div><font class="Apple-style-span" face="arial" size="2">        inet6 ::1 prefixlen 128 </font></div><div><font class="Apple-style-span" face="arial" size="2">        inet 127.0.0.1 netmask 0xff000000 </font></div><div><font class="Apple-style-span" face="arial" size="2">        nd6
 options=3<PERFORMNUD,ACCEPT_RTADV></font></div><div><font class="Apple-style-span" face="arial" size="2">pfsync0: flags=0<> metric 0 mtu 1460</font></div><div><font class="Apple-style-span" face="arial" size="2">        syncpeer: 224.0.0.240 maxupd: 128</font></div><div><font class="Apple-style-span" face="arial" size="2">pflog0: flags=0<> metric 0 mtu 33200</font></div><div><font class="Apple-style-span" face="arial" size="2">wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500</font></div><div><font class="Apple-style-span" face="arial" size="2">        ether 00:24:d8:00:3e:42</font></div><div><font class="Apple-style-span" face="arial" size="2">        inet 192.168.1.21 netmask 0xffffff00 broadcast 255.255.255.255</font></div><div><font class="Apple-style-span" face="arial" size="2">        media: IEEE
 802.11 Wireless Ethernet OFDM/36Mbps mode 11g</font></div><div><font class="Apple-style-span" face="arial" size="2">        status: associated</font></div><div><font class="Apple-style-span" face="arial" size="2">        ssid "My Cisco" channel 6 (2437 MHz 11g) bssid 00:26:75:11:15:20</font></div><div><font class="Apple-style-span" face="arial" size="2">        country US authmode OPEN privacy OFF txpower 15 bmiss 10</font></div><div><font class="Apple-style-span" face="arial" size="2">        scanvalid 450 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7</font></div><div><font class="Apple-style-span" face="arial" size="2">        roam:rate 5 protmode CTS wme roaming MANUAL</font></div><div><font class="Apple-style-span" face="arial" size="2"><br></font></div><div><font class="Apple-style-span" face="arial" size="2">pcbsd# ping
 192.168.1.254</font></div><div><font class="Apple-style-span" face="arial" size="2">PING 192.168.1.254 (192.168.1.254): 56 data bytes                                            </font></div><div><font class="Apple-style-span" face="arial" size="2">64 bytes from 192.168.1.254: icmp_seq=0 ttl=255 time=1.637 ms                                </font></div><div><font class="Apple-style-span" face="arial" size="2">64 bytes from 192.168.1.254: icmp_seq=1 ttl=255 time=1.332 ms                                </font></div><div><font class="Apple-style-span" face="arial" size="2">^C                                  
                                                         </font></div><div><font class="Apple-style-span" face="arial" size="2">--- 192.168.1.254 ping statistics ---                                                        </font></div><div><font class="Apple-style-span" face="arial" size="2">2 packets transmitted, 2 packets received, 0.0% packet loss                                  </font></div><div><font class="Apple-style-span" face="arial" size="2">round-trip min/avg/max/stddev = 1.332/1.485/1.637/0.152 ms                        
           </font></div><div><font class="Apple-style-span" face="arial" size="2">pcbsd# </font></div><div><font class="Apple-style-span" face="arial" size="2"> </font></div></td></tr></table>