Kris, any light you can shed on this... I&#39;ll give this my best shot to recover. It appears that the disks were not formatted and no new partitions were created. Just that the offsets being messed up and the fact that the kernel went missing. if I dd the partitions and pass them to hd, I can see the data still intact... albeit cant quite make sense of it, thanks to geli :-)<br>
<br>I have re-run the PCBSD CD but I have no disks to select in the upgrade.<br><br><div class="gmail_quote">On Tue, Sep 7, 2010 at 8:22 PM, QT <span dir="ltr">&lt;<a href="mailto:rdirective@gmail.com">rdirective@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">You seem to have one bad problem after another.<br><br>The upgrade via PCBSD own system update is binary diffs...it shouldn&#39;t touch your partition layout or the MBR.<br>
<br>Maybe Kris can shed some light about this.<br>
<br>In the mean time, bsdlabel the device to see the partition layout.  Maybe you might want to write down the information in case you need to recreate the partitions in the exact positions<br><br>Quyen<br><br><br><br><div class="gmail_quote">
<div><div></div><div class="h5">
On Tue, Sep 7, 2010 at 11:27 AM, Mike Barnard <span dir="ltr">&lt;<a href="mailto:mike.barnardq@gmail.com" target="_blank">mike.barnardq@gmail.com</a>&gt;</span> wrote:<br></div></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<div><div></div><div class="h5">
Hi....<br><br>It seems that I have had an interesting week. I was upgrading my desktop, which had PCBSD 8.0 to PCBSD 8.1. My initial configuration had a custom partitioning,<br><br>/ -- 2GB UFS<br>/var -- 4GB (journaled and geli&#39;d)<br>



/usr --  50GB (journaled and geli&#39;d)<br>/tmp -- 512M UFS<br clear="all">/work -- 180 (ZFS)<br><br>The upgrade claimed to have gone well, I did not see any re-partitioning or formatting going on. When I rebooted, I ended up with an error<br>



<br>Unable to load a kernel<br>|<br>&#39;Can&#39;t load kernel&#39;<br>Type &#39;?&#39; for a list of commands, &#39;help&#39; for more detailed help.<br>OK<br><br>When I run ls, I can see the boot directory and there is no kernel directory there in. I have booted into live mode and I can see the partitions of the previous installation, only that when I run fdisk &lt;device&gt; I get &quot;<span>fdisk: invalid fdisk partition table found
&quot;<br><br>I have a backup of my keys for geli... any ideas on how to miraculously recover from this :-)... <br><br>PS: My concern is if there was any modification on the partitions when the upgrade happened, then I may never recover my data :-(<br>


<br>PPS: I am tempted, if I can find a way, to copy over my kernel folder from my laptop to my desktop.<br> <br></span>-- <br>Mike<br><br>Of course, you might discount this possibility, but remember that one in<br>a million chances happen 99% of the time.<br>


------------------------------------------------------------<br>

<br></div></div>_______________________________________________<br>
Support mailing list<br>
<a href="mailto:Support@lists.pcbsd.org" target="_blank">Support@lists.pcbsd.org</a><br>
<a href="http://lists.pcbsd.org/mailman/listinfo/support" target="_blank">http://lists.pcbsd.org/mailman/listinfo/support</a><br>
<br></blockquote></div><br><div style="display: inline;"></div>
</blockquote></div><br><br clear="all"><br>-- <br>Mike<br><br>Of course, you might discount this possibility, but remember that one in<br>a million chances happen 99% of the time.<br>------------------------------------------------------------<br>