<div>Hi,<br></div><div><br></div><div>I&#39;ve started enjoying PCBSD recently.</div><div>I have small experience with FreeBSD as well.</div><div><br></div><div>Previously I managed to successfully configure my wireless D-Link DWA-110 on FreeBSD as described in FreeBSD Handbook.</div>
<div>It was OK, but the interface went down from time to time. I just unplugged the adapter form the usb port, plugged in again and proceeded.</div><div>It was not convenient, but I had access to Internet.</div><div>There is no single problem in Windows XP as well.</div>
<div><br></div><div>I installed PCBSD in Desktop mode.</div><div>Unfortunately PCBSD doesn&#39;t pick up the wireless adapter the way it does for wired NICs, so I configured it manually as described in FreeBSD Handbook.</div>
<div>These are:</div><div>1. /boot/loader.conf</div><div>wlan_scan_ap_load=&quot;YES&quot;</div><div>wlan_scan_sta_load=&quot;YES&quot;</div><div>wlan_ccmp_load=&quot;YES&quot;</div><div>wlan_tkip_load=&quot;YES&quot;</div>
<div>2. /etc/wpa_supplicant.conf</div><div>network={</div><div>  ssid=&quot;my ssid&quot;</div><div>  psk=&quot;my psk&quot;</div><div>}</div><div>3. /etc/rc.conf</div><div>ifconfig_rum0=&quot;WPA DHCP&quot;</div><div><br>
</div><div>The problem is that association with wireless router is lost repeatedly. It is offline 95% time actually.</div><div>The adapter got IP configuration from the router once, but it was unable to ping anything but itself. Not even the gateway. </div>
<div>It came to my mind that it can possibly be some misconfigs to default firewall (or ipfilter it is called in PCBSD I guess).</div><div>It appeared to me that configuring firewall in PCBSD is different from FreeBSD.</div>
<div><br></div><div>Please, advise on the firewall configuration (config files, which, where, etc), as well as wireless configuration in total.</div><div>Other ideas are very much appreciated!</div><div><br></div><div>Thanks!</div>