[PC-BSD Support] Eclipse Juno web/EE development

Martijn Veening martijnveening at gmail.com
Sat Nov 2 15:57:08 PDT 2013


After installing Eclipse Juno (Eclipse 4.2.0) in either PC-BSD 9.0 or
9.2, the so-called WTP-functionality is not available (for
EE-development): I cannot create 'Java dynamic web'-projects.
The 'about'-dialogue only shows 'Eclipse Modeling' and 'Eclipse.org'.
I think this is caused by the same issue I encounter trying to 'Check
for updates':

Cannot complete the install because of a conflicting dependency.
  Software being installed: Equinox p2 RCP Management Facilities
1.2.0.v20130827-1605
(org.eclipse.equinox.p2.extras.feature.source.feature.group
1.2.0.v20130827-1605)
  Software currently installed: Eclipse Platform 3.7.0.I20120608-1400
(org.eclipse.platform.ide 3.7.0.I20120608-1400)
  Only one of the following can be installed at once:
    Equinox Java Authentication and Authorization Service (JAAS)
1.2.0.v20130424-1801 (org.eclipse.equinox.security
1.2.0.v20130424-1801)
    Equinox Java Authentication and Authorization Service (JAAS)
1.1.100.v20120522-1841 (org.eclipse.equinox.security
1.1.100.v20120522-1841)
  Cannot satisfy dependency:
    From: Equinox p2 Core Function 1.2.1.v20130827-1605
(org.eclipse.equinox.p2.core.feature.feature.group
1.2.1.v20130827-1605)
    To: org.eclipse.equinox.security [1.2.0.v20130424-1801]
  Cannot satisfy dependency:
    From: Equinox p2 Core Function Source 1.2.1.v20130827-1605
(org.eclipse.equinox.p2.core.feature.source.feature.group
1.2.1.v20130827-1605)
    To: org.eclipse.equinox.p2.core.feature.feature.group [1.2.1.v20130827-1605]
  Cannot satisfy dependency:
    From: Equinox p2 RCP Management Facilities 1.2.0.v20130827-1605
(org.eclipse.equinox.p2.extras.feature.source.feature.group
1.2.0.v20130827-1605)
    To: org.eclipse.equinox.p2.core.feature.source.feature.group
[1.2.1.v20130827-1605]
  Cannot satisfy dependency:
    From: Eclipse Platform
4.2.0.v20120608-135145-9aF7pHdUGEGODPocCvByWfTd46wYyKZWhgf8W0
(org.eclipse.platform.feature.group
4.2.0.v20120608-135145-9aF7pHdUGEGODPocCvByWfTd46wYyKZWhgf8W0)
    To: org.eclipse.equinox.security [1.1.100.v20120522-1841]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.0.I20120608-1400
(org.eclipse.platform.ide 3.7.0.I20120608-1400)
    To: org.eclipse.platform.feature.group
[4.2.0.v20120608-135145-9aF7pHdUGEGODPocCvByWfTd46wYyKZWhgf8W0]

Eclispe 3.5 has always worked flawlessly, but I would really like to
upgrade to 4.2.

Best of regards,
Martijn Veening
The Netherlands


More information about the Support mailing list