[PC-BSD Support] building Samba on 8.2 fails

James D. Parra jamesp at musicreports.com
Tue Jul 24 16:47:59 PDT 2012


Hello,

I had installed Samba35 and had it working with PAM and SSH, however after a reboot PAM broke. Kept getting the error;
in openpam_load_module(): no /usr/local/lib/pam_winbind.so found

The file was actually in that path. Never the less, I tried re-installing;

portsnap extract && portsnap fetch update
cd /usr/ports/devel/libtool && make deinstall && make install clean
cd /usr/ports/security/krb5 && make deinstall
make KRB5_HOME=/usr/local install clean

and finally;
cd /usr/ports/net/samba35 && make KRB5_HOME=/usr/local install clean

With my fingers crossed I hoped for the best and yet I received the following error during compiling;

<snip>
Compiling libsmb/libsmb_setget.c
libsmb/libsmb_setget.c: In function 'smbc_getOptionUseCCache':
libsmb/libsmb_setget.c:427: error: 'SMB_CTX_FLAG_USE_CCACHE' undeclared (first use in this function)
libsmb/libsmb_setget.c:427: error: (Each undeclared identifier is reported only once
libsmb/libsmb_setget.c:427: error: for each function it appears in.)
libsmb/libsmb_setget.c: In function 'smbc_setOptionUseCCache':
libsmb/libsmb_setget.c:435: error: 'SMB_CTX_FLAG_USE_CCACHE' undeclared (first use in this function)
The following command failed:
cc -I/usr/local/include -O2 -pipe -DLDAP_DEPRECATED -fno-strict-aliasing -I. -I/usr/ports/net/samba35/work/samba-3.5.15/source3 -I/usr/ports/net/samba35/work/samba-3.5.15/source3/iniparser/src -Iinclude -I./include  -I. -I. -I./../lib/replace -I./../lib/tevent -I./libaddns -I./librpc -I./.. -DHAVE_CONFIG_H  -I/usr/local/include -I/usr/local/include -Iinclude -I./include -I. -I. -I./../lib/replace -I./../lib/tevent -I./libaddns -I./librpc -I./.. -I./../lib/popt -I/usr/local/include -DLDAP_DEPRECATED  -I/usr/ports/net/samba35/work/samba-3.5.15/source3/lib -I.. -I../source4 -D_SAMBA_BUILD_=3 -D_SAMBA_BUILD_=3  -fPIC -DPIC -c libsmb/libsmb_setget.c -o libsmb/libsmb_setget.o
gmake: *** [libsmb/libsmb_setget.o] Error 1
*** Error code 1

Stop in /usr/ports/net/samba35.
*** Error code 1

Stop in /usr/ports/net/samba35.
<snip>


Does anyone have any solutions on how I can get Samba installed and resolve the above error?

Many thanks in advance.


James 


More information about the Support mailing list