[PC-BSD Support] Scrubbing unclean disk

Lynn Steven Killingsworth blue.seahorse.syndicate at gmail.com
Wed Dec 5 14:10:51 PST 2012


Hi PC-BSD -

I thought I would say also that under SU I issued this command:

fsck -y -F -t /dev/gptid/98d1fd52-f450-11e1-9426-c86000707666 and my  
machine executed the command.  Still after restarting I get the same error  
for each drive.  I have been advised previously that perhaps I should have  
tried zspool hence my question.

An error occurred while accessing '1.8 TiB Hard Drive', the system  
responded: org.freedesktop.Hal.Device.Volume.UnknownFailure: mount:  
/dev/gptid/98d1fd52-f450-11e1-9426-c86000707666: R/W mount of  
/media/98d1fd52-f450-11e1-9426-c86000707666 denied. Filesystem is not  
clean - run fsck.: Operation not permitted

Hi PC-BSD -

I have one available storage disk in my workstation and one available USB
backup disk.  Without being an expert after I installed 9.1 RC-1 I used
gpart to make my partition on each drive and format them zfs as GPT.  So I
do not have a pool I think to which they belong.  I have 9.1 RC-3 now and
I have been trying audio and video players.  So I caused the PC-BSD to
just close and reboot when I clicked on my DVD.  So now my storage and USB
disks are unclean and I cannot mount them.  FSCK of course has no command
for zfs file system.  From the forums if I had a pool I would use zspool
scrub [pool] and then zspool clear [pool].  How may I try that on a disk
that I have not included in a pool.  zspool list of course shows my root
partition as tank0.

PS - The Audacious audio player has really outstanding sound.  It took me
about 20 minutes to determine how to use it.  Actually I rebooted PC-BSD
on 2 video players then I discovered that finally Dragon Player is working
this build - although the video is really nice movement on the screen
isn't quite smooth.

-- 
Steve
Poetry and commentary on the war;
http://www.blueleafsyndicate.org

Using Opera's mail client: http://www.opera.com/mail/


More information about the Support mailing list