[PC-BSD Support] Very strange network issues on PCBSD 8.1 (i386)

Sam Lin semin2006 at gmail.com
Sat Jan 1 04:05:43 PST 2011


Hi all -

I recently came across with a couple of issues regarding the network.

1. I have been using a “Captive Portal” to connect to the Internet on
PCBSD in my office; although need to launch a browser to enter my user
name and password to get connect to the Internet every time I boot
PCBSD, at least I have not had big problem with it. On the other hand,
I have also been trying to use the Internet from my house but through
normal ADSL but for unknown reasons I have never been able to connect
to the Internet at home despite out adsl modem and the network are in
fact working (tested with Windows machine). The network device on my
laptop is working for sure (tested by installing Windows on it and try
the network out). Both wired and wireless on PCBSD appeared not being
able to get connect to the Internet at home. For your information, my
network devices on my laptop are:

- Wired: sis0 (NatSemi DP8381[56] 10/100BaseTX); detected at bootup
- Wireless: wlan0 (Ralink 54M USB from TP-Link TL-WN321G); detected at bootup

- ADSL modem: DSL-G604T

As I am not going to the office during the Xmas break and the captive
portal is not covering my house, I have had to try all the ways I
could try to get the network work at home on PCBSD. Ultimately I came
to a very strange solution but never failed to "activate" the network
on my laptop on PCBSD. Below is the step:

(1) Before start up the PCBSD machine make sure that network cable (or
usb network adapter) is plugged onto the laptop
(2) Start up the PCBSD machine
(3) Wait until PCBSD and KDE are fully launched. At this stage the
network device status shows "associated" but the Internet is not
working on this laptop.
(4) Unplug the network cable/usb network adapter
(5) Right click on the network icon in systray, pick "Restart the
Network" and enter root's password.
(6) Plug the network cable or usb network adapter back to the laptop
(7) Wait for 5-10 seconds (?)
(8) Now finally the Internet is working on this laptop with PCBSD.

There are several strange things here. First, at step (3) the network
is not working, which is very odd. Second, if I leave the cable
plugged and just "restart the network", the network is then still NOT
working. Third, unplug then re-plug cable/usb adapter without
"restarting the network" still does NOT activate the network. Lastly,
after step (6), clicking "check for updates" in SystemUpdaterTray
straight away would show that the network is not working unless I
launch a browser and connect to a website (does not matter what
website it is). For this one I am not sure whether it means I need to
"activate my network" by launching a browser, or merely mens I need to
wait for awhile before the network on this laptop actually starts to
work... But anyway, whilst I finally get the network working on my
laptop with PCBSD, this is no doubt confusing and annoying.

Has anyone having the same experience (I hope I am not the only person
facing this issue)? How do I manage to sort out this network issue?

2. I was managing to ask the question given above on PCBSD IRC
channel, then realised that once I launch IRC client and connect to
Freenode, our network in the house froze and I could do nothing but to
turn off and then turn on the power point on the wall for the adsl
modem. No matter how many times I try or what IRC network/channel I
try to connect, the whole network in my house just get frozen all of a
sudden. Tried XChat and Pidgin but all same consequence. It's just
like a bomb!

Has anyone having the same experience ? And how do I manage to sort
out this network issue?


Regards,
Sam


More information about the Support mailing list