[PC-BSD Support] Lost kernel/partitions upgrading from 8.0 to 8.1

Mike Barnard mike.barnardq at gmail.com
Tue Sep 7 09:27:09 PDT 2010


Hi....

It seems that I have had an interesting week. I was upgrading my desktop,
which had PCBSD 8.0 to PCBSD 8.1. My initial configuration had a custom
partitioning,

/ -- 2GB UFS
/var -- 4GB (journaled and geli'd)
/usr -- 50GB (journaled and geli'd)
/tmp -- 512M UFS
/work -- 180 (ZFS)

The upgrade claimed to have gone well, I did not see any re-partitioning or
formatting going on. When I rebooted, I ended up with an error

Unable to load a kernel
|
'Can't load kernel'
Type '?' for a list of commands, 'help' for more detailed help.
OK

When I run ls, I can see the boot directory and there is no kernel directory
there in. I have booted into live mode and I can see the partitions of the
previous installation, only that when I run fdisk <device> I get "fdisk:
invalid fdisk partition table found "

I have a backup of my keys for geli... any ideas on how to miraculously
recover from this :-)...

PS: My concern is if there was any modification on the partitions when the
upgrade happened, then I may never recover my data :-(

PPS: I am tempted, if I can find a way, to copy over my kernel folder from
my laptop to my desktop.

-- 
Mike

Of course, you might discount this possibility, but remember that one in
a million chances happen 99% of the time.
------------------------------------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/support/attachments/20100907/bdc11da9/attachment.html>


More information about the Support mailing list