[PC-BSD Support] automake, Canon software, etc

Dru Lavigne drulavigne at sympatico.ca
Thu Aug 19 18:16:02 PDT 2010


Do you still have the CD that came with the printer? If so, does it contain a PPD file? That's what you really want.

A quick Google search and it seems that Canon wants to give you a nice big installation program rather than just the driver (the PPD).

Cheers,

Dru

> Date: Fri, 20 Aug 2010 09:51:14 +1000
> From: rob1940 at gmail.com
> To: support at lists.pcbsd.org
> Subject: [PC-BSD Support] automake, Canon software, etc
> 
> Dear Helpers,
> 
>   I'm trying to install support for a Canon LBP 7200Cdn printer
> (colour laser printer, duplex, networking - good value).  Canon have
> their own page description language (CAPT) but provide software to
> integrate with CUPS so that the printer can be used (converts from
> postscript to CAPT, I think).  The software is provided in .deb and
> .rpm formats and I'm not sure if these can be installed in PCBSD as
> packages.  Canon also supplies the source, complete with makefiles.
> And this is where the problem lies:
> 
> 1.  The software uses "automake" and "autoconf", well-known building
> tools.  However, on PCBSD these two are not in the standard path,
> instead they reside in /Programs/K3B/bin.  Why is is this?  I can put
> this into my path and then access them to do the build, but I'd like
> to know what I am doing.  Why aren't they in /usr/local/bin or
> somewhere like that?  Is there any harm in using /usr/ports/devel to
> make autoconf and automake and have them installed in a more standard
> place?
> 
> 2.  The supplied version of automake has a problem:
> 
> pcbsd [9:46] ~>which automake
> /Programs/K3B/bin/automake
> pcbsd [9:47] ~>automake --version
> Can't locate Automake/Struct.pm in @INC (@INC contains:
> /Programs/K3B/share/automake-1.10 /usr/local/lib/perl5/5.10.1/BSDPAN
> /usr/local/lib/perl5/site_perl/5.10.1/mach
> /usr/local/lib/perl5/site_perl/5.10.1 /usr/local/lib/perl5/5.10.1/mach
> /usr/local/lib/perl5/5.10.1 .) at /Programs/K3B/bin/automake-1.10 line
> 48.
> BEGIN failed--compilation aborted at /Programs/K3B/bin/automake-1.10 line 48.
> 
> Should I use the ports system to put in new versions of autoconf and automake?
> 
> My system is:
> 
> pcbsd [9:47] ~>uname -a
> FreeBSD pcbsd 8.0-RELEASE-p2 FreeBSD 8.0-RELEASE-p2 #4: Thu Jan  7
> 09:20:42 PST 2010
> root at build8x32.pcbsd.org:/usr/obj/usr/pcbsd-build80/fbsd-source/8.0-src/sys/PCBSD
>  i386
> 
> Thanks for the help.
> 
> Cheers,
> Rob Hurle
> -- 
> -----------------------------
> Rob Hurle
> ANU, College of Asia and the Pacific
> School of Culture, History and Language
> Histories of Asia and the Pacific
> e-mail:              rob1940 at gmail.com
> Telephone (ANU): +61 2 6125 3169
> Mobile (in VN):  +84 948 243 538
> Mobile (in OZ):  +61 417 293 603
> -----------------------------
> _______________________________________________
> Support mailing list
> Support at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/support
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/support/attachments/20100820/070ad884/attachment.html>


More information about the Support mailing list