[PC-BSD Support] ndis not working with bcmw5l_sys.ko

Linux sqlpython at sbcglobal.net
Sun Aug 3 17:35:08 PDT 2008


Kris
 ..this is long so Thanks in Advance for your response.
using ndisgen and my bcmwl5.inf and sys files I produced a bcmwl5_sys.ko which worked great with PCBSD 1.3 and 1.4 for my Dell truemobile wifi.
ndis and if_ndis and the bcmwl5_sys.ko are not working with PCBSD 1.51.
The card scans No Wifif Networks and I have several.
 I tried the old bcmwl5_sys and a new one generated with ndisgen on PCBSD 1.51 both are recognized by the system and the network manager but No Signal. The wired card works fine but this laptop without a wireless is useless to me.
Below are  listings of  /boot/loader.conf  ..ifconfig..kldstat..dmesg
 ....The bfe0 is Broken 2yrs..the dc0 is my working Wired Cat5 a PCMCIA Netgear NIC..
I am also sending a link to a screen shot. 
http://usera.imagecave.com/sqlpython/sqlpython_PCbsd1.5.png

pcbsd# cat /boot/loader.conf
linux_load="YES"
ulpt_load="YES"
#vesa_load="YES"
#splash_pcx_load="YES"
#bitmap_load="YES"
#bitmap_name="/boot/loading-screen.pcx"
hw.ata.atapi_dma="1"
autoboot_delay="5"
kern.ipc.shmseg=1024
kern.ipc.shmmni=1024
ndis_load="YES"
if_ndis_load="YES"
BCMWL5_SYS_load="YES"           

 [sqlpython at pcbsd /usr/home/sqlpython]$ ifconfig
bfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        ether 00:0f:0b:9e:0f:de
        media: Ethernet autoselect (none)
        status: no carrier
ndis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        ether 00:80:4c:25:71:5f
        media: IEEE 802.11 Wireless Ethernet autoselect
        status: no carrier
        ssid "" channel 1
        authmode OPEN privacy OFF txpowmax 100 bmiss 7 protmode CTS
fwe0: flags=108802<BROADCAST,SIMPLEX,MULTICAST,NEEDSGIANT> mtu 1500
        options=8<VLAN_MTU>
        ether 42:4e:d0:72:04:63
        ch 1 dma -1
pfsync0: flags=0<> mtu 2020
        syncpeer: 224.0.0.240 maxupd: 128
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
        inet6 ::1 prefixlen 128
        inet 127.0.0.1 netmask 0xff000000
pflog0: flags=0<> mtu 33208
dc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        inet 192.167.2.112 netmask 0xffffff00 broadcast 192.167.2.255
        ether 00:0f:a5:55:d5:de
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
[sqlpython at pcbsd /usr/home/sqlpython]$
***********************************
[sqlpython at pcbsd /usr/home/sqlpython]$ kldstat
Id Refs Address    Size     Name
 1   29 0xc0400000 7ab3a4   kernel
 2    2 0xc0bac000 1eed0    linux.ko
 3    1 0xc0bcb000 3890     ulpt.ko
 4    2 0xc0bcf000 ca04     if_ndis.ko
 5    3 0xc0bdc000 17734    ndis.ko
 6    1 0xc0bf4000 84a54    BCMWL5_SYS.ko
 7    1 0xc0c79000 5c264    acpi.ko
 8    1 0xc53df000 6000     linprocfs.ko
 9    1 0xc5584000 6000     snd_ich.ko
10    1 0xc5596000 1d000    sound.ko
11    1 0xc5911000 1e000    radeon.ko
12    1 0xc592f000 e000     drm.ko
*********************
pcbsd# dmesg
Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.3-RELEASE-p2 #7: Thu Apr 17 11:21:34 EDT 2008
    root at pcbsd:/usr/obj/usr/src/sys/PCBSD
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2392.04-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf27  Stepping = 7
  Features=0xbfebf9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x4400<CNXT-ID,xTPR>
real memory  = 1073516544 (1023 MB)
avail memory = 1037107200 (989 MB)
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <DELL CPi R  > on motherboard
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci_link1: BIOS IRQ 11 for 0.31.INTB is invalid
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82845G host to AGP bridge> mem 0xe0000000-0xe7ffffff at device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xbf80-0xbf9f irq 11 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xbf40-0xbf5f irq 11 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xbf20-0xbf3f irq 11 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0: <Intel 82801DB/L/M (ICH4) USB 2.0 controller> mem 0xf4fffc00-0xf4ffffff irq 11 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <Intel 82801DB/L/M (ICH4) USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci_link1: BIOS IRQ 11 for 2.1.INTA is invalid
pci2: <ACPI PCI bus> on pcib2
bfe0: <Broadcom BCM4401 Fast Ethernet> mem 0xfaffe000-0xfaffffff irq 9 at device 1.0 on pci2
miibus0: <MII bus> on bfe0
bmtphy0: <BCM4401 10/100baseTX PHY> on miibus0
bmtphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bfe0: Ethernet address: 00:0b:db:9d:0f:dd
ndis0: <Dell TrueMobile 1300 WLAN Mini-PCI Card> mem 0xfaffc000-0xfaffdfff irq 11 at device 2.0 on pci2
ndis0: NDIS API version: 5.1
ndis0: Ethernet address: 00:90:4b:28:79:6f
cbb0: <TI4510 PCI-CardBus Bridge> at device 4.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
fwohci0: <1394 Open Host Controller Interface> mem 0xfaffb800-0xfaffbfff,0xfaff4000-0xfaff7fff irq 11 at device 4.1 on pci2
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 42:4f:c0:00:22:84:08:61
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 42:4f:c0:84:08:61
fwe0: Ethernet address: 42:4f:c0:84:08:61
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc000ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH4 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xbfa0-0xbfaf at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
pci0: <multimedia, audio> at device 31.5 (no driver attached)
pci0: <simple comms, generic modem> at device 31.6 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64,0x62,0x66 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> flags 0x1000 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcefff,0xcf000-0xcf7ff,0xcf800-0xcffff on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 2392040980 Hz quality 800
Timecounters tick every 1.000 msec
cardbus0: Resource not specified in CIS: id=10, size=100
cardbus0: Resource not specified in CIS: id=14, size=400
dc0: <Netgear FA511 10/100BaseTX> port 0xd000-0xd0ff mem 0xf6001000-0xf60013ff irq 11 at device 0.0 on cardbus0
miibus1: <MII bus> on dc0
ukphy0: <Generic IEEE 802.3u media interface> on miibus1
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
dc0: Ethernet address: 00:0f:b5:45:d3:ae
acd0: CDRW <HL-DT-STCD-RW/DVD-ROM GCC-4243N/A102> at ata0-master UDMA33
ad0: 38154MB <HITACHI DK23EB-40 00K0A0C0> at ata1-master UDMA100
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
cd0 at ata0 bus 0 target 0 lun 0
cd0: <HL-DT-ST RW/DVD GCC-4243N A102> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Trying to mount root from ufs:/dev/ad0s1a
pcm0: <Intel ICH4 (82801DB)> port 0xb800-0xb8ff,0xbc40-0xbc7f mem 0xf4fff800-0xf4fff9ff,0xf4fff400-0xf4fff4ff irq 9 at device 31.5 on pci0
pcm0: <SigmaTel STAC9750/51 AC97 Codec>
drm0: <ATI Radeon LW RV200 Mobility 7500 M7> port 0xc000-0xc0ff mem 0xe8000000-0xefffffff,0xfcff0000-0xfcffffff irq 11 at device 0.0 on pci1
info: [drm] AGP at 0xe0000000 128MB
info: [drm] Initialized radeon 1.25.0 20060524
info: [drm] Setting GART location based on new memory map
info: [drm] writeback test succeeded in 1 usecs
pcbsd#       
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/support/attachments/20080803/3fe8e650/attachment.html 


More information about the Support mailing list