[PC-BSD Support] PC-BSD on HP Compaq 6720s

Mike Barnard mike.barnardq at gmail.com
Wed Dec 19 01:59:14 PST 2007


Hi Khris,

Yes, it did seem a bit strange for me since i do know that the em drivers do
work on FreeBSD6.0 stable. I downloaded 1.4.1 which i see has FreeBSD
6.3Prerelease, but it also does not work.

For the wireless card, I tried a work around using drivers for windows xp
and ndisgen to convert them, but still no results. The wifi card is an
"Intel 3945ABG Wireless LAN Controller".

The ethernet card is an "Intel 82562GT 10/100".

Thanks.

Regards

On Dec 19, 2007 12:05 AM, Kris Moore <kris at pcbsd.com> wrote:

>
>
> Mike,
>
> Thats strange that em0 wouldn't work on PC-BSD 1.4, but it does work on
> 6-STABLE, considering that PC-BSD 1.4 is built on 6-stable, although it
> may be a bit older of a release.
>
> Did you try updating to 1.4.1, or installing the 1.4.1 ISO's? That
> release uses a bit newer codebase with FreeBSD 6.3-PRERELEASE under the
> hood.
>
> As for the wifi card, which model Intel is it using? We'll have to see
> if the iwi driver works with it, or else you may need to use ndisgen to
> roll a new driver for it.
>
> --
>
> Kris Moore
> PC-BSD Software
> http://www.pcbsd.com
>
>
> Mike Barnard wrote:
> > Hi,
> >
> > I downloaded PC-BSD 1.4 and had a successful install on an HP Compaw
> > 6720s laptop. Apart from the lack of wide-screen for KDE, i dont seem
> > to have network functionality at all. I also do not have the wireless
> > card detected, i dont see it in the dmesg entries nor in the log
> > files. My network card is present, em0, but cannot connect to the
> > network.
> >
> > I have statically assigned the IP addresses on it, but to no avail,
> > dhclient em0 returns 'No DHCPOFFERS received. No working leases in
> > persistent database - sleeping'. I have ruled out my DHCP server since
> > all other connections to it are working fine, FreeBSD 6.2 stable works
> > well without any problems and so does linux (Xandros 3.0.2).
> >
> > While trying to obtain an IP address, tcpdump reports this:
> >
> > IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from
> > 00:1a:4b:73:d5:98 (oui Unknown), length: 300
> >
> > Is there something broken in this release, any fixes for it? Any
> > assistance in getting this working is appreciated.
> >
> > Regards,
> >
> >
>



-- 
Mike

Of course, you might discount this possibility, but remember that one in
a million chances happen 99% of the time.
------------------------------------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/support/attachments/20071219/a6022925/attachment.html 


More information about the Support mailing list