[Pbibuild] PBI-7 Autobuild (amd64): editor/abiword/

PC-BSD Build7 (amd64) root at build7x64.pcbsd.org
Sun Nov 29 17:59:30 PST 2009


PBI Autobuild results for module editor/abiword/:
Status: Failed

View Folder:
ftp://ftp.pcbsd.org/pub/pbioutgoing/x64/7/outgoing/editor/abiword//

File listing:
-rwxr-xr-x  1 root  wheel  20819902 Sep 23 11:41 AbiWord2.6.8_4-PV0.pbi
-rw-r--r--  1 root  wheel        64 Nov 29 20:59 AbiWord2.6.8_4-PV0.pbi.md5
-rw-r--r--  1 root  wheel    566059 Nov 29 20:59 build.log.bz2
-rw-r--r--  1 root  wheel         0 Nov 28 21:26 build.time
-rw-r--r--  1 root  wheel         7 Nov 29 19:19 dirstatus
-rw-r--r--  1 root  wheel        16 Sep 23 11:41 mdate

PBI MD5:
MD5 (AbiWord2.6.8_4-PV0.pbi) = ad98c7ee9e53cc55abf66161dfcf37f3


Last 50 lines of build.log
---------------------------------------------------
checking whether gcc understands -Wpointer-arith... yes
checking whether gcc understands -Wshadow... yes
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking for jpeg_read_header in -ljpeg... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for DEPS... configure: error: Package requirements (
  fribidi >= 0.10.4
  glib-2.0 >= 2.6.0 gthread-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0
  libgsf-1 >= 1.12
  wv-1.0 >= 1.2.0
  enchant >= 1.2.0 gio-2.0 gucharmap-2 
  cairo-pdf cairo-ps pangocairo
  gtk+-2.0 >= 2.12.0 gtk+-unix-print-2.0 librsvg-2.0 >= 2.16.0
) were not met:

gnome-config: not found
No package 'librsvg-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEPS_CFLAGS
and DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

===>  Script "configure" failed unexpectedly.
Please run the gnomelogalyzer, available from
"http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the
problem and suggest a solution. If - and only if - the gnomelogalyzer cannot
solve the problem, report the build failure to the FreeBSD GNOME team at
gnome at FreeBSD.org, and attach (a)
"/usr/ports/editors/abiword/work/abiword-2.8.1/config.log", (b) the output
of the failed make command, and (c) the gnomelogalyzer output. Also, it might
be a good idea to provide an overview of all packages installed on your system
(i.e. an `ls /var/db/pkg`). Put your attachment up on any website,
copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with
the attachment. Try to avoid sending any attachments to the mailing list
(gnome at FreeBSD.org), because attachments sent to FreeBSD mailing lists are
usually discarded by the mailing list software.
*** Error code 1

Stop in /usr/ports/editors/abiword.
ERROR: 2.1 Build failed of editor/abiword/!!!


More information about the Pbibuild mailing list