<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 08/16/2012 13:29, John Katzmaier
      wrote:<br>
    </div>
    <blockquote
cite="mid:CA+wWMwdR7SRp0KkuiSctUrWqq=uamLe9EuhVTPdWkUHNqJg4hw@mail.gmail.com"
      type="cite">
      <pre wrap="">Hi,

I sometimes like to use an offline calculator and math/galculator is a
nice lightweight one that gets the job done. I didn't see a PBI for it
already, so I created one on PC-BSD 9.1-BETA1 using EasyPBI. It is
attached and it is not signed.

It does get the following errors when ran from the command-line, but
they seem to be pretty common non-fatal GTK errors that a lot of
applications experience. The application worked fine for me. Here are
the errors I get when running the application from the command-line:

(galculator:41612): Gtk-WARNING **: Unable to locate theme engine in
module_path: "qtcurve",

(galculator:41612): GLib-GObject-CRITICAL **: g_object_ref: assertion
`G_IS_OBJECT (object)' failed

(galculator:41612): Gdk-CRITICAL **: IA__gdk_window_set_icon_list:
assertion `GDK_IS_PIXBUF (pixbuf)' failed

(galculator:41612): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width:
assertion `GDK_IS_PIXBUF (pixbuf)' failed

(galculator:41612): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height:
assertion `GDK_IS_PIXBUF (pixbuf)' failed

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): Gtk-WARNING **: GtkSpinButton: setting an
adjustment with non-zero page size is deprecated

(galculator:41612): GLib-GObject-CRITICAL **: g_object_unref:
assertion `G_IS_OBJECT (object)' failed

-John Katzmaier
</pre>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Pbi-dev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Pbi-dev@lists.pcbsd.org">Pbi-dev@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/pbi-dev">http://lists.pcbsd.org/mailman/listinfo/pbi-dev</a>
</pre>
    </blockquote>
    <br>
    Thanks for sending it in!<br>
    I just added this module to our build servers. The PBI should be
    available in the AppCafe once it builds and gets tested/approved.<br>
    The module's do not get signed themselves, just the actual PBI when
    it is created, so no worries about that.. :-)<br>
    Also, as you already mentioned, those errors are fairly common for
    some GTK apps, so as long as the program still works properly I
    wouldn't worry too much about them.<br>
    <br>
    Thanks again!<br>
    <br>
    <pre class="moz-signature" cols="72">-- 
~~ Ken Moore ~~
PC-BSD/iXsystems</pre>
  </body>
</html>