<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    On 11/02/11 02:07, Tigersharke . wrote:
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">Hello..<br>
      <br>
      I would make these suggestions:<br>
      <ul>
        <li>At initial start or after reset, Dim/Grey-out and/or set
          'inactive' the fields and buttons.</li>
      </ul>
    </blockquote>
    I will look into doing this a little later. It takes quite a bit to
    ensure that all the buttons are enabled at the proper times.... :-)<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>Remove the superfluous popup error messages due to clicking
          buttons at initial start or after reset.<br>
        </li>
      </ul>
    </blockquote>
    This has changed quite a bit, try out the new version and see if it
    is any better.<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>
          <br>
        </li>
        <li>Pre-fill the icon value with "defaulticon.png", but
          dimmed/inactive at initial start/reset. (GUI as default is
          pre-checked).</li>
      </ul>
    </blockquote>
    I prefer that the icon chosen is empty initially as this provides a
    clean interface on startup. When you select a port to build a module
    for, then it sets the icon to defaulticon.png.<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>Values that cannot be changed once filled-in automatically,
          should not be editable (such as the port name) and the value
          instead be displayed in simple bold text.</li>
      </ul>
    </blockquote>
    Fixed!<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>In addition to highlighting the standard ports location,
          expand it one level further (showing accessibility, archivers,
          arabic.. etc).<br>
        </li>
      </ul>
    </blockquote>
    It looks like that is how the Qt directory retrieval dialog works,
    by not expanding the starting directory. To get around this I set
    the starting directory one level deeper (ports/accessibility) so
    that it is initially expanded.<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>Possiblity of a "guess at GUI", due to certain dependencies,
          libraries, or other attributes of the port chosen.</li>
      </ul>
    </blockquote>
    I think this is a good idea, that way the user is informed as to
    what type of app the selected port is determined to be.<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>If the standard ports tree is used/chosen (easily known due
          to its proper path) other assumptions and checks
          (idiot-proofing) can be made.<br>
        </li>
      </ul>
      <div style="margin-left: 40px;"><br>
      </div>
    </blockquote>
    Let me know what types of checks you are thinking about, and we can
    work something out!<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">I like the method of traversing the ports tree to
      locate the port. This may be slightly tedious, but its a good way
      to relate to the ports tree, and certainly a nice touch to be able
      to paste the path (such as one obtained from a browse of <a
        moz-do-not-send="true" href="http://freshports.org">freshports.org</a>).<br>
      <br>
      I am using KDE with 64bit v9.0rc1, EasyPBI v0.3..<br>
      <br>
      ERROR:<br>
      <ul>
        <li>If after initial start or reset, the GUI checkbox is clicked
          (to remove the tick) EasyPBI immediately crashes with a seg
          fault.</li>
      </ul>
    </blockquote>
    Jesse, the error comes from trying to change
    pbi_data->console_app. You might want to check how your structure
    is defined and make sure it is a public variable.<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>If a port is chosen, then the fields are all reset, the
          message does not revert to "To get started, please select "New
          Module" from the file menu."<br>
        </li>
      </ul>
    </blockquote>
    Fixed!<br>
    <blockquote
cite="mid:CAHRv5yicLembkcHTpeyXqCeMAa57TPZy71x8WZ_27Ox4AQ8-7A@mail.gmail.com"
      type="cite">
      <ul>
        <li>
          <br>
        </li>
      </ul>
      <div style="margin-left: 40px;"><br>
      </div>
      Thanks for your efforts!<br>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Pbi-dev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Pbi-dev@lists.pcbsd.org">Pbi-dev@lists.pcbsd.org</a>
<a class="moz-txt-link-freetext" href="http://lists.pcbsd.org/mailman/listinfo/pbi-dev">http://lists.pcbsd.org/mailman/listinfo/pbi-dev</a>
</pre>
    </blockquote>
    <br>
    I am attaching the newly updated version of EasyPBI. The GUI now
    supports building PBI files, but the actual code to perform that is
    not finalized yet, so it will just return a "Not Implemented Yet"
    message. However, the GUI stuff for setting up the PBI-build
    settings should work just fine.<br>
    <br>
    Let me know if you have any suggestions!<br>
    <br>
    <pre class="moz-signature" cols="72">-- 
~~ Ken Moore ~~
PC-BSD/iXsystems</pre>
  </body>
</html>