On 15 March 2011 08:00,  <span dir="ltr"><<a href="mailto:pbi-dev-request@lists.pcbsd.org">pbi-dev-request@lists.pcbsd.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
Date: Mon, 14 Mar 2011 11:17:56 -0400<br>
From: Kris Moore <<a href="mailto:kris@pcbsd.org">kris@pcbsd.org</a>><br>
To: <a href="mailto:pbi-dev@lists.pcbsd.org">pbi-dev@lists.pcbsd.org</a><br>
Subject: Re: [PC-BSD Pbi-dev] PBI module for LibreOffice - with some<br>
        glitch<br>><br>
> Sam,<br>
><br>
> I have just finished comparing LibreOffice 3.3.1 and OpenOffice 3.2.1<br>
> (both downloaded with the software manager). I am unable to reproduce<br>
> this slowness that you described in LibreOffice. I also verified that<br>
> both LibreOffice and OpenOffice have nearly identical visual effects and<br>
> integration within KDE. Whether this is a KDE3 or KDE4 integration I<br>
> cannot speak to, but it appears to match my desktop theme fairly well<br>
> without appearing "old".<br>
><br>
> As such, I do not see a reason to remove LibreOffice from pbidir at this<br>
> time. If you find an error that I<br>
> can reproduce, I will consider removing the PBI.<br>
><br>
> ~Ken Moore<br>
<br>
I've also been running LibreOffice 3.3.1 on the CURRENT snapshots, and<br>
it seems just fine, no slow-downs that I can think of. Visually it looks<br>
the same as my regular open-office does.<br>
<br>
Is there anything unique to your setup Sam that I could do to try and<br>
replicate these issues? Do you have any extra port / WM stuff installed?<br>
<br>
<br>
--<br>
Kris Moore<br>
PC-BSD Software<br>iXsystems<br>
</blockquote><div><br></div><div>Hm... that's really strange. Rumor is that the code base of LibreOffice is half as much as that in OpenOffice, and also I actually felt when compiling LibreOffice that it's slimmer than OpenOffice and I cannot see why it's so sluggish on my system. Even though my laptop is a bit old (AMD Athlon XP-M 2400+, 1024MB RAM, 120GB HD, ATI Radeon Mobile U1), OpenOffice 3.2.1 responds much better than LibreOffice 3.3.1.<br>
</div><div><br></div><div>I thought it was because I had played around with KDE4 desktop themes on my 8.2 (i386), but trying reinstalling the whole PCBSD system and then reinstall LibreOffice straight away still gave the same sluggish response. Tried both "radeon" and "vesa" graphic drivers but did not give any difference e.g. still gives half-and-incomplete pulldown menu as shown in the previously attached screenshots.</div>
<div><br></div><div>As for the appearance, it does look a bit close to OpenOffice once I switch the icons in my LibreOffice from the default "automatic" to "small classic", although it still does not reflect the style of my current KDE4 theme at all...</div>
<div><br></div><div>Can you send me some screenshots of your both LibreOffice and OpenOffice and let me see how it looks like on your system?</div><div><br></div><div>Perhaps I should also post this on the forum and see how LibreOffice is performing on others' systems.</div>
<div><br></div><div>Sam</div>